[SOLVED] Deal Breaker or am I missing something basic?

Tags: #<Tag:0x00007f7451c98430>

Hello all!

First post from a newbie trying to migrate from my current Vera-setup. After spending many hours I have a basic understanding to start building my setup, but now I encountered a problem I’m not sure how to solve. I have many wall plugs in my house (Fibaro FGWPF-102) that I successfully can control from the BasicUI which means that my things, items and sitemap seems to be working as they should. The problem is that if someone changes the state of a wall plug by switching it ON or OFF by using the physical b-button on the wall plug itself, that state change isn’t reflected in my basic UI. This was not a problem in my Vera-setup using the same plugs - in that UI, a physical state change was reflected in the UI more or less instantaneously.

So, what am I missing? Should this be automatically updated on the switch-item through the channel? Should there be an event caught by a rule when the button is pressed that will change the state in OH? Or could this be a device-binding problem in OH, and if so, is this a common problem shared by other Z-wave devices?

Btw, I have tried to search the forum for information but haven’t really found anything conclusive.

Any help appreciated!
Thanks,
Christian

  • Platform information:
    • Hardware: Raspberry Pi 3b with Aeotec Z-stick Gen5
    • OS: OpenHABian 1.5 based on Debian Buster
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.4.0 Stable
1 Like

Welcome! There are two possible issues I can think of. The first will be easy to check… just manually switch a device ON or OFF and then refresh the page in your browser to see if things update. If they do, this is an issue with SSE that has been resolved for a while.

If that is not the problem, the second issue is that your devices may not have associations set to the controller. This is what updates the state of the devices when you manually control them. There have been a lot of changes in OH this year and the 2.5 stable release is a bit behind schedule. Included in the changes are some fixes for the zwave binding (I’m assuming that is what you are using) that improves associations. You could go in and manually cleanup the associations, but they will likely eventually all drop again. It will be a lot easier and helpful for many other reasons, to upgrade OH to the latest 2.5 milestone release (M4). You could upgrade just the zwave binding, but there really is no reason not to upgrade OH to 2.5M4. The 2.5 stable release should be out before the end of the year.

Be safe and always do a backup before upgrading! I don’t use openHABian, but there is a lot of info in the forum for how to use it to upgrade OH to a milestone build.

1 Like

Thanks!

I tried both refresh and restart/reload of the app yesterday without any luck.

I will give 2.5M4 a try to see if it solves my problem (correct, zwave binding is what I’m using). Installing OpenHABian in the first place was a bit of a pain due to some issues with Java, but hopefully everything is sorted out now. A backup is of course needed and the configuration files are straight forward. Just need to figure out how to backup my “things” since they are managed in some kind of internal database. Back to the documentation … again :upside_down_face:

You will find your managed Things in the jsondb, which is just JSON text files. Things are in $OPENHAB_USERDATA/jsondb/org.eclipse.smarthome.core.thing.Thing.json.

1 Like

You can just use the integrated backup function to backup your configuration:


Johannes

Did you migrate your ZWave devices to OH or are they still with the Vera and you use the mios binding ?
If the latter, that probably does not work because the Vera does not forward stuff to OH as it believes to be the (only) controller itself.
The controller’s ID is stored in the devices when you include them so you need to ex/reinclude them with your new controller when you migrate.

1 Like

The devices were excluded from Vera, factory-reset and added to OH. They work just fine when controlling them from within the OH Basic UI.

You might now need to set lifelines in the devices, to report unsolicited events.

This is done for you in the current version of the binding. There are several topics discussing this.

I managed to upgrade OpenHAB and the Z-wave binding to 2.5M4 yesterday, but the problem is still the same. I can probably live with it for now but would like to know that this is at least supposed to work.

Maybe I should investigate associations and see if i can verify it with my devices.

I think to get all features of binding changes, you need to delete Things and re-create them, you don’t mention doing that.

1 Like

Ahh ok, makes sense! Will try that!

Also take a look at your association groups. There may be more than one and the binding will only force the controller to Group 1. Look in Habmin and the manual for the device (which you can find in the device database… cdjackson.com).

I was looking for Habmin just to realize that it wasn’t part of my installation, so I decided to start all over from scratch… After a couple of hours reinstalling everything all is well. The wall plugs report back to OpenHAB what they should.

1 Like

I could be missing something but my zwave devices are all on my vera edge and OH updates just fine when I change things either physically at a switch or digitally via the Vera UI(s). I’m using the Mios binding to connect the two systems together. I don’t use any zwave features of OH as I’m running OH on a VM and the vera does a solid job as a zwave controller.