[SOLVED] Debugging in 2.5.x

I used the last documentation to install an IDE with 2.5.x addons. It works really great but the issue I face when modifications done on code, the debugger always run on original version of the binding. Does anyone has a hint ?

I’ve tried to rebuild, clean… nothing works.
Forgot to mention I’m using app.bndrun in OSGi. Modified pom.xml to include my bundle.

I’m assuming you have the binding in your ide so that should not be the problem. Are you sure the binding you set in the demo pom has the same version of your binding as the binding you have in eclipse?

Here what I added to the pom.xml :


And when I do resolve on the app I see he uses :
org.openhab.binding.freebox located in the .m2 folder
I suspect the problem is there.

What version has the demo app pom.xml itself, I suspect 2.5.1(-SNAPSHOT)? It should be the same version as your binding pom or change the version of your binding in the demo pom to the version of your binding.

You’re a boss @hilbrand, I changed version demo app pom.xml to 2.5.2-SNAPSHOT and this works !

I installed the lates 2.5.x open hab demo app and the adding to implement my own stuff. To be sure that the installation was successful, then I built the original “xmppclient” binding (without any changes). The build (clean install) was successful also. But the demo app is not able to resolve the dependencies.

I added the xmppclient binding in the pom of the demo app, still the demo app has some failed dependencies. (my system is macOS 10.15.2, Java™ SE Runtime Environment (build 1.8.0_231-b11))

I get this error

Resolution failed. Capabilities satisfying the following requirements could not be found:
      ⇒ osgi.identity: (osgi.identity=org.openhab.binding.xmppclient)
          ⇒ [org.openhab.binding.xmppclient version=]
              ⇒ osgi.wiring.package: (&(osgi.wiring.package=org.jivesoftware.smack.packet)(&(version>=4.3.0)(!(version>=5.0.0))))
                  ⇒ [org.igniterealtime.smack.core version=4.3.3]
                      ⇒ osgi.wiring.package: (&(osgi.wiring.package=org.xmlpull.v1))

What do I do wrong?