[SOLVED] Debugging OH exit, what can cause this?

Hi all,

I have tried searching through the forum, but I haven’t found anything (maybe because there is nothing I can do…).
So it seems that OH on my setup shut downs after a random time… for example few days ago, it exited in hours and also freezed my RPi for minutes before exiting and restarting the service. I have tweaked the config a little bit and it seems that the freeze is gone. However sometimes OH still exits… (and right after systemctl restarts it).

Are there any chance debugging what can cause this? There is no specific error or anything in the log:

2018-11-30 23:43:15.083 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'kodi:kodi:3f43baed-3db0-0fc1-98e8-287603bb3896' to inbox.
2018-11-30 23:43:15.320 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'kodi:kodi:3f43baed-3db0-0fc1-98e8-287603bb3896' to inbox.
2018-11-30 23:44:09.286 [INFO ] [.internal.GenericScriptEngineFactory] - Activated scripting support for ECMAScript
2018-11-30 23:44:12.118 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to 'Europe/Budapest'.
2018-11-30 23:44:12.139 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to '47.527504699999994,19.1130335'.
2018-11-30 23:44:12.150 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to 'en_HU'.

You can see that almost a minute passed since it started loading again. And only this service gets restarted, any other thing running it runs stable.
On the systemctl status page I can only see the exit code, which is 1 (not so talkative…).


What version of openhab are you running? Are you using VS Code?

Yes I’m using VSCODE, but I dont think it is in connection with the exit caused by vscode.

Yes, you’re right. This VS Code induced restart was fixed in M6, so it might be something else.

However it seems hard for me to debug this because none of the logs contains any error message. Maybe turning some logging to higher level could help on this but I dont know where to start

I don’t have much else to offer.

When faced with these situations I remove bindings one at a time until the problem goes away. Then I add back the most recently removed binding and see if the problem reoccurs.

If you’re running off an SD card, perhaps the card is corrupted. That often causes odd behavior.