[SOLVED] Defining USB serial drives not working as aspected

Hi,

I’m having 2 USB serial devices connected to my openhabian system, but since they keep switching between ttyUSB0 and ttyUSB1 I want them to give an alias so they have fixed names.

So I followed this instruction: https://www.openhab.org/docs/administration/serial.html#serial-port-configuration

I used the command: udevadm info -a -p $(udevadm info -q path -n /dev/ttyUSBX) were I replaced the X with the matching number.

With that info I filled out the lines with the info like this:
SUBSYSTEM==“tty”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“8293”, ATTRS{serial}==“04000BB6”, SYMLINK+="ttyTeleUSB”

SUBSYSTEM==“tty”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, ATTRS{serial}==“AC2OETAX”, SYMLINK+="ttySlimmeUSB”

The idVendor and idProduct numbers are also showing with command “lsusb” so there are defiantly correct, the serial was in the same column as the idVendor and idProduct so I figured that I should be correct as well, I placed both lines in /etc/udev/rules.d/99-com.rules underneath the other SUBSYSTEM lines.

After that I rebooted the pi, unfortunately the USB didn’t get the aliases but still have USB0 and USB1, what am I doing wrong…?

Found the problem.
Apparently, in the example the quote sign isn’t really a quote but a 2 single quotation marks so the values waren’t correct, after I replaced all single quotation marks with a quote sign, it worked just fine :slight_smile: