[SOLVED] Documentation mistake? sudo dpkg -i zulu8.38.0.13-ca-jdk8.0.212-linux_amd64.deb

  • Platform information:
    • Hardware: Raspberry Pi 4 / 4 GB RAM
    • OS: Raspbian Buster Lite (26.09.2019)
    • Java Runtime Environment:

root@raspberrypi:/opt/jdk# java -version
openjdk version “1.8.0_212”
OpenJDK Runtime Environment (Zulu8.38.0.163-CA-linux_aarch32hf) (build 1.8.0_212-b163)
OpenJDK Client VM (Zulu8.38.0.163-CA-linux_aarch32hf) (build 25.212-b163, mixed mode, Evaluation)

I’m hanging on this step of installation guide:

https://openhabdoc.readthedocs.io/de/latest/Raspberry/

sudo dpkg -i zulu8.38.0.13-ca-jdk8.0.212-linux_amd64.deb

German:
root@raspberrypi:/opt/jdk# sudo dpkg -i zulu8.38.0.13-ca-jdk8.0.212-linux_amd64.deb
dpkg: Fehler: Auf das Archiv »zulu8.38.0.13-ca-jdk8.0.212-linux_amd64.deb« kann nicht zugegriffen werden: Datei oder Verzeichnis nicht gefunden

Another mistake I found in the docs:

sudo rm ulu8.38.0.163-ca-jdk1.8.0_212-linux_aarch32hf.tar.gz

Right version:

sudo rm zulu8.38.0.163-ca-jdk1.8.0_212-linux_aarch32hf.tar.gz

Can you help me with this step with dpkg?

Thanks!

Why use a third party guide instead of official documentation? Using openHABian is easiest or you can use the official installation guide.

For Java they direct you to Azul’s site.

There is no mistake in the official documentation. If you want to correct that documentation I guess you could try filing an Issue on their GitHub page.

1 Like

That particular error is because the file does not exist in the directory you are in.
But as @Bruce_Osborne already responded, that’s not the official docs. So we can’t comment or correct them - you would need to contact the authors.

Either way, a better recommendation is to get openHABian:


That now IS a link to the official docs :slight_smile:

1 Like

Thank you I try it again with openHABian :slight_smile:!

Hmmmm :frowning: :

openHABian v1.5 based on Debian Buster supports RPi4

Attention! The openHABian setup process seems to have failed on your system.
Sorry, this shouldn’t happen! Please restart the installation process. Chances
are high setup will succeed on the second try.

2019-07-10_01:21:53_BST [openHABian] Starting the openHABian initial setup.
2019-07-10_01:21:53_BST [openHABian] Storing configuration… OK
2019-07-10_01:21:53_BST [openHABian] Starting webserver with installation log… OK
2019-07-10_01:21:58_BST [openHABian] Changing default username and password… OK
2019-07-10_01:21:59_BST [openHABian] Setting up Wi-Fi connection… OK, rebooting…
2019-07-10_01:22:12_BST [openHABian] Starting the openHABian initial setup.
2019-07-10_01:22:12_BST [openHABian] Storing configuration… OK
2019-07-10_01:22:12_BST [openHABian] Starting webserver with installation log… OK
2019-07-10_01:22:17_BST [openHABian] Changing default username and password… SKIPPED
2019-07-10_01:22:17_BST [openHABian] Setting up Wi-Fi connection… OK
2019-07-10_01:22:21_BST [openHABian] Ensuring network connectivity… OK
2019-07-10_01:22:21_BST [openHABian] Waiting for dpkg/apt to get ready… OK
2019-12-05_23:35:52_GMT [openHABian] Updating repositories and upgrading installed packages… OK
2019-12-05_23:39:02_GMT [openHABian] Installing git package… OK
2019-12-05_23:39:16_GMT [openHABian] Cloning myself… OK
2019-12-05_23:39:18_GMT [openHABian] Executing ‘openhabian-setup.sh unattended’…
2019-12-05_23:39:18_GMT [openHABian] Checking for root privileges… OK
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists…
2019-12-05_23:39:22_GMT [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2019-12-05_23:39:22_GMT [openHABian] Setting timezone based on openhabian.conf… OK (Europe/Berlin)
2019-12-06_00:39:22_CET [openHABian] Setting locale based on openhabian.conf… OK
2019-12-06_00:39:58_CET [openHABian] Setting hostname of the base system… OK
2019-12-06_00:39:59_CET [openHABian] Setting the GPU memory split down to 16MB for headless system… OK
2019-12-06_00:39:59_CET [openHABian] Enabling Audio output… OK
2019-12-06_00:39:59_CET [openHABian] Installing basic can’t-be-wrong packages (screen, vim, …)… OK
2019-12-06_00:40:35_CET [openHABian] Installing additional needed packages… OK
2019-12-06_00:41:16_CET [openHABian] Adding slightly tuned bash config files to system… OK
2019-12-06_00:41:16_CET [openHABian] Adding slightly tuned vim config file to system… OK
2019-12-06_00:41:16_CET [openHABian] Downloading and setting up FireMotD… chmod: cannot access ‘/tmp/FireMotD’: No such file or directory
FAILED
2019-12-06_00:41:18_CET [openHABian] Installing Java Zulu 32-Bit OpenJDK…
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
FAILED
2019-12-06_00:41:18_CET [openHABian] Initial setup exiting with an error!

What I do is I follow the Linus openHABian instructions on Raspbian Lite.
That works well on a Pi too.

Errr, you installed in July, stopped and continued today ?
openHABian code from July has issues that have been fixed meanwhile.
Please install from scratch. As you have a RPi, better use the image than to install Raspbian yourself.

I use the lastest release form https://github.com/openhab/openhabian/releases “openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz”. Wasn’t this the right way?

Now it seems working. I do the following:

sudo rm -R /opt/openhabian
sudo reboot