(solved) Empty Chart in Openhab App, but it works fine if opened via URL in the browser

Strange, opening my chart via URL works fine:

However, if i open it in openhab App (iPhone, or Browser) the chart is empty. Anyone an idea on whats wrong?

Number EG_F2_Herd_Verbrauch "F2 Herd Verbrauch: [%.3f kW]" <energy> (gStromverbrauchAll) {knx="<9.024:0/2/1"}

Chart item=EG_F2_Herd_Verbrauch icon="energy" period="12h" service="mysql"

Strategies {
every15m : "*/15 * * * * ?"
everyHour : "0 0 * * * ?"
everyDay : "0 0 0 * * ?"
default = everyChange, everyDay

    Items {
    gStromverbrauchAll*    :    strategy = everyChange, every15m, everyHour, everyDay 
    * : strategy = default, restoreOnStartup

I faced the same issue after enabling authentification (user name, password) in OH 1.7 and 1.8 using rrd4j persistence. Disabling authentfication solves the issue, which i do not consider a long-term solution.


Thanks, well I do not use username / password for OpenHab. Also, I am using openhab 1.8 and mysql.

Here we go, YES! Solved! I do not really understand the difference, but placing service=“mysql” on an other position seems to make the difference.

Instead of:
Chart item=EG_F2_Herd_Verbrauch icon="energy" period="12h" service="mysql"

I am using now:
Chart item=EG_F2_Herd_Verbrauch service=“mysql” icon=“energy” period=“12h”

1 Like

You should open an issue; that’s stange.