[SOLVED] Error flashing openhabian xz to sd card using etcher

I formatted SD card using SD Formatter. When Etcher gets to 100% it crashes with an error about “radix argument” and leaves sd card unaddressable. Does anyone know what this might be? Tried 3 times with identical result. SD card is 16GB.

Try another SD card…

1 Like

Thanks. Just have and get identical behaviour.

I don’t use windows so…
Try to download the image again. Maybe it’s corrupt.
Use another software than etcher

there is an pretty new issue for that on github:

unfortunately no solution but it seems to happen also with different images.
But i would try re-downloading the image again as @vzorglub suggested.

I was flashing the latest raspian just a few days ago with Etcher and Win10 and haven’t had any issues

Thanks. Can I just unzip with, say, 7Zip and copy the .img file onto the sd card?

No. Then you have a sd card with the IMG file. You need a software to create the boot partition and all of the other magic that is required

Can you recommend alternative software other than etcher which sounds as though there is a problem with windows 32 bit. p.s. i have redownloaded the xz file with no change of behaviour.

No, sorry.
have you looked into on of these:

Win32 disk imager should work but you need to in compress the image first.

Thanks. I have now succeeded with 7-Zip and Win32DiskImager.

1 Like

Good, well done.
Please mark the thread as solved. Thanks