[Solved] Error to load Rules

I have some problems with my rules: I write my rules with Visual Studio Code Openhab Extention.
But when I upload my xxx.rules file to /etc/openhab2/rules and go to Habmin Rules Habmin says: Error to load Rules.

rule “OG”


Item Ligth_Switcher_Anna_Colorligth changed





Thank you for your help.

What do the logs say?

If you are using VSCode you probably do not need to mess with Habmin rules tools at all - they were never finished, and will not be now.

Yes, but the rule doesn’t work at all.

Here is the log:

2020-01-18 12:15:31.249 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model ‘OG.rules’
2020-01-18 12:15:33.120 [ERROR] [e.internal.items.GroupFunctionHelper] - Group function ‘AND’ requires
two arguments. Using Equality instead.

That’s nothing to do with rules. You have a defective Group Item description somewhere.

You’ll need to investigate.
The Item you are trying to trigger from has a misspelling. That’s okay, if it matches the actual Item.
Look in your events.log for the Item change that you expect to trigger this rule.

i kown but the first line has something to with rules?

Light :wink: But that’s not your Problem only a Typo :wink:

I think the whole Rule makes not sense … Trigger and sendCommand are the same…

What would you do?

Yes, it is telling your rules file has been loaded. That is a Good Thing, and always worth checking after you have been editing - sometimes it will tell you about syntax errors instead.

Oh yea sry xD

My events.log file is empty. But i can controll my items

I’ve reninstalled it now, and now it works but i’ve a other problem now. I linked a switch thing to my presence sensor. My sensor recognizes Movements but the Switch of my thing doesen’t “Switch”

I expect your presence sensor has something to do with some binding or other. We can’t guess.

1 Like