[Solved] Evohome 2.4.0 - No binding found that supports creating a thing of type 'evohome:account'

openHab 2.2.0 docker. Running on a QNAP TS453Be NAS.

I have installed the EvoHome binding, but I cannot get it to create a thing and connect to the honeywell web service. When I create a thing for the account it remains with an UNINITIALIZED status.

I have found in the error logs a message.

Is this a bug in the binding?

Or, is it an issue in my installation?

Thanks, George

2019-06-24 19:59:13.820 [WARN ] [ore.thing.internal.ThingRegistryImpl] - Cannot create thing. No binding found that supports creating a thing of type ‘evohome:account’.

I think that is because, according to the documents, it is of type Bridge.

See https://www.openhab.org/addons/bindings/evohome/#demo-things

I think the “bug” is not referencing the documentation, but asking here first :wink:

Thank you for the reply. Please do not make the assumption I have not read the documentation. I have read it over and over and over. And then search the forums. I have done this over several days. This message really is a last resort.

Can you please elaborate on what you think is wrong or that I have misunderstood?

I need to create the account (which is a thing) which contains my password and userid. I think that this can be done with a file or on the PaperUI.

When I create it in the PaperUI I get the ‘thing’ appearing, but it never gets past the uninitialized status.

Are you sure the username & password are correct? Perhaps you could delete the thing & try creating manually like this.

    Bridge evohome:account:your_account_alias [ username="your_user_name", password="your_password" ]
        display your_display_alias  [ id="1234" ]
        heatingzone your_zone_alias [ id="5678" ]

I have tried that and nothing appeared. Should I have restarted openhab? I was under the impression that a restart is not needed.

That text was created it in the things directory in a file called evohome.things.

Yes, I am sure the username and password is correct. I assume that the alias values are not important and the defaults will work.

Though, if the password/username did not wort I was expecting that this would be shown in the log.

I assume username & password are enclosed in double quotes. If they were unrecognized I would expect it to be uninitialized.

They are in double quotes.

I am getting the error mentioned in the original post:
Cannot create thing. No binding found that supports creating a thing of type ‘evohome:account’.

So, back to my questions:

  • So I need to restart openhab when changing a thing file?

  • Does this error message seem like there is an error in my configuration, or a problem in the binding JAR file which needs raising with the developer?

I think your next step should be to demonstrate that the package is in fact installed.
bundle:list|grep -i evo

“It depends” not every binding is good at picking up in-flight changes. The symptom would of course be “nothing happens” rather an error in response to edits.

I can see that it is there and ‘waiting’:
openhab> bundle:list | grep evo
231 │ Waiting │ 80 │ 2.4.0 │ evohome Binding

I am beginning to think that this is a problem within the binding…

Waiting is not functional.
Try this advice

Thank you. I have tried clearing the caches, reinstalling and re configuring multiple times. The problem still exists and I am getting the same following log error:

2019-06-27 07:25:19.814 [WARN ] [ore.thing.internal.ThingRegistryImpl] - Cannot create thing. No binding found that supports creating a thing of type ‘evohome:account’.

What happens if you just use the PaperUI? Install the binding that way, then use the PaperUI config to enter the username & password?

I seem to remember early on I couldn’t get it to accept the username & password via text config. Once I had entered the info via PaperUi it worked.

If I use the .things file the thing does not appear.

When I create it using the PaperUI it appears, but the then it will not initialize.

Having maybe created the thing, has your binding moved on from ‘waiting’ ?

It’s not clear - are you running OH 2.2 and trying to install binding 2.4 ?

1 Like

Thank you SOOOOOOO much. Yes, this was exactly the problem.

I did not realise that there is a dependency between the version on the binding and openhab.

I changed the JAR file and it now works!!!

Sometimes, sometimes not; trying to jump two version numbers is probably a bit ambitious though.