[SOLVED] Expire: not expiring?

Hmm, expire worked well in OHv1.
Now I am on OHv2 and have the following item:

Number   GeoLoc_MaxG_Vel		"Max's speed is [%.0f km/h]"			<speedo>	(gGeoMax, gGeoMax_Chart, gPersist_rrd4j) { expire="5m,0" }

… which does not send the zero after 5 minutes.
I have tried “5m,state=0”, “5m,command=0”, which did not work either.

The binding docu tells me “5m,0” seems the right command for updating a number.
The expire binding is installed and active, according to console and PaperUI.

Works for me with numbers, including zero, even negative.

Need to look for updates on that Item?

1 Like

Ouch! No updates coming in, no expire trigger being set… this hurts.
I am sure it will work when I am driving tomorrow. (A holiday today here in AU.)


I don’t know, maybe it’s about clearing caching when editing an Item.
{ expire=“5m,0” } definitely works as expected in OH2.4

You are getting a trigger to begin with? i.e. expire does not “auto start” at boot time. Nor does it do anything if state is already, or changes to, the target 0.

Make a test Item with a much shorter time as a demo?

All good. All clear…
Maybe I wasn’t explicit with my reply…
It is exactly that: no update coming in for this item, thus no trigger, hence, nothing to see. :slight_smile:

I updated the item over the console and expire worked as designed!

1 Like