[SOLVED] Failed notifying listener

I have this error message:

2018-12-22 15:10:22.119 [WARN ] [pse.smarthome.core.items.GenericItem] - failed notifying listener 'avgTemps (Type=GroupItem, BaseType=NumberItem, Members=1, State=15.900390, Label=null, Category=null)' about state update of item avgTemps: null

Reading on the forum I think I understand that it is a Null value that is not correctly interpreted.
I tried to disable every single sensor from the group to understand if one of the values ​​created a problem, but nothing.
Should I debug, but I do not know what bindings, to better understand if there is an error, or is a rule better that eliminates the Null value problem?
this is the sitemap:

Text item = avgTemps

item file:

Group: Number: AVG avgTemps "average temperature [% .1f ° C]" <temperature> (avgTemps)

Number Temperature_day "daytime temperature [% .1f ° C]" <temperature> (avgTemps, TechnicView_Node3) {souliss = "T52: 3: 18"}
Number Temperature_corridor "corridor temperature [% .1f ° C]" <temperature> (avgTemps, TechnicView_Node1) {souliss = "T52: 5: 0"}
Number Temperature_camera "room temperature [% .1f ° C]" <temperature> (avgTemps, TechnicView_Node2) {souliss = "T52: 2: 3"}
Number Temperature_studio "studio temperature [% .1f ° C]" <temperature> (avgTemps, TechnicView_Node12) {souliss = "T52: 12: 9"}

Thanks for your suggestions

NULL and null are two different things,

NULL - indicates an Item is not yet initialized
null - part of the language, indicates that a variable does not have a value

Do you get the temp reading if using just one item without groups and trying to average?

thanks for the explanation on the differency of the definition NULL.
To answer your question, do you mean if I have a reading in the average value by inserting only one sensor in the group?
If this is the question, the answer is yes, and they are the same

Shouldn’t it be 4??

Change the item definition:
Remove the space between Number: and AVG
And remove the group at the end (A group can’t belong to itself!)

Number:AVG avgTemps "average temperature [% .1f ° C]" <temperature>

now the mistake is gone. Thank you
So my mistake was to have put (avgTemps)
in Group: Number: AVG avgTemps
and any writing errors
I got it


Please mark the topic solved by clicking the square box on the post that provided the solution and edit the title to start with [Solved]. This will help others, with a similar issue, find a quick solution.