[Solved] FGS221 - Return State nok


I use OH2.4 and I’ve a issue with my Fibaro fgs221.
It’s work I can switch ON OFF perfectly in OH and with the WallSwitch.
But If I use the WallSwitch Openhab does not update the status (ON/OFF).

I check in community and found the same with FGS222, I try to use the solution

Switch relay0 "relay0 [%s]" { zwave="6:command=SWITCH_BINARY" }
Switch relay1 "relay1 [%s]" { zwave="6:1:command=SWITCH_BINARY" }
Switch Relay2 "relay2 [%s]" {zwave="6:2:command=SWITCH_BINARY" }

My switch is node 6 but it’s the same.
I try to change parameter also (13) but not working.

You are using the config for openHAB1, you need to link the channels to items in openHAB2.

Switch relay1 "relay1 [%s]" { channel="zwave:device:your_controller_id:node6:switch_binary1" }
Switch relay2 "relay2 [%s]" { channel="zwave:device:your_controller_id:node6:switch_binary2" }

Make sure you have your associations set to your controller. As there are several different FGS221 in the database please look up the correct group in the database matching your firmware version:

1 Like

Thank you again.

You saves me again :blush: