[SOLVED] Fibaro Door/Window sensor 2 (FGDW-002) not sending door open

I have just installed the neat FIBARO DOOR/WINDOW SENSOR 2
FGDW-002 in my Z-wave network, on OH2.1.

Inclusion was easy - and device is detected. After a bit of time, I start receiving temperature and battery readings.

My problem is however, that there are no reports sent at door open/close and at tamper-alerts.

In my zwave log, everything looks fine with the device - I just dont receive the reports…

Considering I bought the device for the purpose of open/close alerts - I am not too happy, even if it is nice to see how warm it is in that room :wink:

Anyone who have a working setup with this device who would like to share their config ? (settings & items-file) ?

Are there really no one who has this sensor ?

Sadly, you are not alone. There is no way I have gotten this sensor to work… bought 4 at once… close to regretting the decision.

There are some other form posts and GitHub issues about similar reports, however, I did not found a solution so far. Others have, but did not explained how they did it.

If someone does have them working… let us know how please.

For reference:

While I’m not sure as I’ve not tested this myself, I suspect this is related to the change in association handling. You could try the development version to see if this helps -:

Hi Chris,

Thanks for the swift response, and, I have not fully tested it yet, I have gotten one of the sensors working as expected!

Thank you so very much!

Hi @MaxvandeLaar,

I’m excited😊 Please do tell; what is working now?

My Fibaro is in my weekend-house which I won’t see until - the weekend :slight_smile:

But already now I see that the binding version I am using there is:

openhab> bundle:list | grep ZWave
225 | Active   |  80 |     | ZWave Binding

I guess that would be the development pack you mentioned @chris ?

And that is what doesnt work with with my Fibaro…

Hi @martindk

I have all my sensors recognised and online now. 2 out of 4 have working Contact sensors reporting open/closed correctly. The other 2 I still have to check (will try this tonight) as they took over 12 hours before being recognised. But I guess this will work fine.

For 1 of 2 working devices I have also setup the temperature and battery sensors. Both these sensors are working as expected.

Note: I have my OH2 installed on an ubuntu server via apt installation.

1 Like

Could you share your bindings and explain what you did to make them work?

Having the exact same problem!

OK - I have now been able to get the sensor working perfectly in OH2.1 as well.

I get door OPEN/CLOSE at door open/close - and I get tamper-alerts as ON/OFF. The sensor also sends temperature and battery readings every 5-6 hours.

I believe the trick was indeed to install Chris’ development version of the z-wave binding; follow the directions from Chris’ earlier post in this discussion.

As directed, you need to de-install your current z-wave binding in PaperUI, download the development jar-file as Chris directed, and place it in your add-on folder.

In my installation, all the z-wave items then needed to be deleted and re-found, in order to show online again.

Then, for this sensor, you need to configure the device association groups so that your controller will get the call when the door opens. I set both association group 2 and 3 to my controller (Node 1). I then set my configuration parameters like this:
1: closed when magnet near
3: 2nd group “ON/OFF” sent as secure
11: Switch after opening and closing
12: 99

These are my items:

Contact	xDoor      		"Door [%s]"     		<contact>    	{ channel="zwave:device:36f36c45:node6:sensor_door" }
Switch	xPowerAlarm     "Power Alarm [%s]"		<switch>		{ channel="zwave:device:36f36c45:node6:alarm_power" }
Switch	xTamperAlarm    "Tamper Alarm [%s]"		<switch>		{ channel="zwave:device:36f36c45:node6:alarm_tamper" }
Number	xTemperature	"Door Temp [%.1f °C]"	<temperature>	{ channel="zwave:device:36f36c45:node6:sensor_temperature" }
Number	xBattery		"Door Battery [%d %%]"	<energy>		{ channel="zwave:device:36f36c45:node6:battery-level" }

It took me a bit to figure out how to get the development version of the binding installed. The reason was that I needed to install the serial feature (mentioned in Chris’ post) and for that, I needed to log in to the (Karaf) console, which I had never done before and therefore needed to google around for directions.

Finally - I found that I had also managed to install the sensor in the wrong way; make sure that the small magnet sensor meets the main sensor where there is a marking on the side of it. It is described well in the manual for the sensor - but somehow I had failed to read that :wink:

As said - everything is working well now, and I am ready to install more of these sensors.

Only worry at this point is, that my battery says 55% after two weeks usage - but I also think that the battery was already a bit worn as I got it - so I will keep an eye on it for now and make sure I have some spare batteries around. The manual says up to 2 years battery life…

Thank you for your excellent explanation!

I will try this out real soon :wink:
Can I ask which other Z-Wave devices you are using?
I am doing a big project for university so I am testing different brands and products before buying a lot of them.

I have:

USB Sticks:
Aeon Labs Z-Stick Gen5 - Zw090
Z-Wave.Me ZME_UZB1 USB Stick

Qubino ZMNHID Flush on/off thermostat
Qubino ZMNHCD Flush Shutter
Qubino ZMNHBD Flush 2 relays
Everspring SP103 Motion Detector
LogicHome ZHC5010 FUGA Wall 4-way Switch with LED + Relay
Danfoss LC-13 Living Connect Z Thermostat
Aeon Labs ZW096 Smart Switch 6
Aeon Labs ZW100 MultiSensor 6
Aeon Labs Recessed Door Sensor GEN5 ZW089
Fibaro FGDW-002 Fibaro Door Window Sensor 2

All are working well with OH2.1

1 Like

Just for the record, I had similar issues and it took me hours and hours to find out how to solve it on my side.

The situation was:

  • the device had been detected correctly and included by openhab
  • when I woke up the device openhab did receive the wake up data
  • I had a battery reading


  • I got no open / close reading
  • I seems I couldn’t transfer any settings to the device

I tried to include and exclude the device several times, which in some occasions had helped me before but now without any success.

What finally helped me was

  • to exclude the device
  • to RESET the device (you need to be away that this is even possible)
  • to include the device
  • and voila it works as expected

Resetting the sensor isn’t that easy. This is what you have to do (taken from the manual)

  1. Open the cover.
  2. Remove the battery.
  3. Install the battery while holding both TMP buttons.
  4. Visual LED indicator will be flashing slowly for 5 seconds - keep
    holding the buttons.
  5. Release one button when the LED indicator starts flashing quickly.
  6. Click released button once to confirm launching of reset procedure.
  7. Wait a few seconds until a long blink of the LED indicator. Do not
    remove the battery.
  8. Visual LED indicator will blink 5 times quickly to confirm the reset.

Hope that helps to avoid the many hours searching for a solution (which almost had me put to a point to throw away the sensor)


1 Like

I am running into the same situation as some others. The sensor is partially functioning (temperature/battery) but the door sensor won’t respond.
After some playing I round I noticed that moving the battery from one site to the other resulted in it working correctly. Touching on one side would send an Open signal, touching the other side would send a Closed signal. Each was only sent once when touching one site multiple times. I also noticed a soft tick when moving the magnet. Based on this I would say that at least for my units the internal magnet sensor is ‘sticking’ and won’t spring back when the magnet is removed (when you open the door) it requires the extra pull of the magnet on the other side to un-stick it.
For me this is specifically happening for two recently bought units, several older ones are still functioning.

1 Like

I am actually having a similar problem with the fibaro motion sensor. In the beginning it worked for months - now since quite some time even though it is detected in openhab it refuses to send any events to the controller anymore (although motion detection works as it is indicated by the leds). I finally have given up the device which is a pity… :disappointed: :cry:

I suggest to delete the Thing, then run zwave discovery. Then add it from the inbox again. If you have unmanaged Items, check the Channel configuration, in case it has changed. If it still doesn’t report, exclude the device and reinclude.

1 Like

Thanks Scott for the hint. Though I have tried that several times in the past and it still doesn’t receive events…

What version of the binding are you using? I would strongly recommend using the latest if you are not already doing so (ie 2.4 M4 or newer - M5 should be out tomorrow).

Currently I am using the development version and I am kind of afraid to change as usually with all changes I had quite some work until all my actors/sensos would all work again (I have like 40…).

The current one I am using is is in the addons folder. What do I have to do?

  1. Don’t work with the dev version anymore and go back to the official OH version?
  • Stop OH
  • Remove jar from the addons folder
  • and now use openhabian-config to upgrade openhab? (if how)
  1. Or still go for the addons-folder and replace by M5?


There is no dev version now, so I would definitely recommend moving to the standard OH version. The dev version was merged to master a couple of months ago now I think.

Since you are already on the development version, in theory it shouldn’t be too much hassle to update - you shouldn’t have to do anything to all your devices.

So, if I remove it from the addons folder, how exactly do I upgrade to the latest openhab version? Via openhabian and there do an upgrade of OH ?