[SOLVED] Fibaro FGMS-001 - cannot see alarm OFF/ON in GUI (PaperUI)

I added the binary, temperature, and seismic intensities channels in PAperUI (img2) and I see the following event messages (snapsho1)

The Binary sensor is blank in Control (img1) and I want it to show OFF/ON when motion is undetected/detected.
I was told in this post to make the following associations

  • Lifeline -> openHAB controller
  • Motion -> openHAB controller
    I set it up in Habmin, but I’m seeing a yellow pending comment (img3)
    How do I make the yellow pending comment to go away, so that the value gets persisted?
    I tried waking up the device, but it did not help.


tail -f /var/log/openhab2/events.log
2017-03-26 12:47:59.923 [ItemAddedEvent            ] - Item 'zwave_device_02710de3_node6_sensor_binary' has been added.
2017-03-26 12:47:59.924 [ItemChannelLinkAddedEvent ] - Link 'zwave_device_02710de3_node6_sensor_binary-zwave:device:02710de3:node6:sensor_binary' has been added.
2017-03-26 12:48:01.539 [ItemAddedEvent            ] - Item 'zwave_device_02710de3_node6_sensor_temperature' has been added.
2017-03-26 12:48:01.539 [ItemChannelLinkAddedEvent ] - Link 'zwave_device_02710de3_node6_sensor_temperature-zwave:device:02710de3:node6:sensor_temperature' has been added.
2017-03-26 12:48:02.766 [ItemStateChangedEvent     ] - zwave_serial_zstick_02710de3_serial_sof changed from 60 to 61
2017-03-26 12:48:02.888 [ItemAddedEvent            ] - Item 'zwave_device_02710de3_node6_sensor_seismicintensity' has been added.
2017-03-26 12:48:02.888 [ItemChannelLinkAddedEvent ] - Link 'zwave_device_02710de3_node6_sensor_seismicintensity-zwave:device:02710de3:node6:sensor_seismicintensity' has been added.


tail -f /var/log/openhab2/openhab.log
017-03-26 12:46:29.592 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 6: Already processed another send data request for this callback Id, ignoring.
2017-03-26 12:46:34.569 [WARN ] [ocol.ZWaveController$ZWaveSendThread] - NODE 6: Too many retries. Discarding message: Message: class=SendData[0x13], type=Request[0x00], priority=Immediate, dest=6, callback=9, payload=06 01 00




The solution was to present the OFF/ON events in basicui instead of PaperUI

After restarting openhab2, the pending comment went away (img1)
But the Binary, Motion, Tamper and general alarms still do not indicate OFF/ON (img2) :frowning:
Any other ideas how to make the indications show up?



Did you wake up the device after changing the configs in habmin?
Open battery tray and triple click the small button. This wakes the device which will force downloading the changed config. I do this 3 to 4 times to make sure the new config is active in the device. Then refresh habmin.

I did it and it seems that the initialisation went fine (no log messages).
I do see the OFF/ON events (snapshot1), but nothing shows up in the PaperUI Control


tail -f /var/log/openhab2/events.log
2017-03-26 13:39:31.506 [ItemStateChangedEvent     ] - zwave_serial_zstick_02710de3_serial_sof changed from 181 to 182
2017-03-26 13:39:31.508 [ItemStateChangedEvent     ] - zwave_device_02710de3_node6_alarm_motion changed from OFF to ON
2017-03-26 13:39:57.434 [ItemStateChangedEvent     ] - zwave_serial_zstick_02710de3_serial_sof changed from 182 to 183
2017-03-26 13:39:57.436 [ItemStateChangedEvent     ] - zwave_device_02710de3_node6_alarm_motion changed from ON to OFF

Ahh, got you. The device is ok, but its a paperUI issue instead.
I would not recommend relying on PaperUI for this as displaying the current status is not PaperUI’s core functionality.
Add an item to your thing and diplay it in basicui.

Thanks @waitz_sebastian I moved to using basicui instead of PaperUI and I can see the OFF/ON indication.

There are multiple alarms on the device
sensor_binary (Binary Sensor)
alarm_general (Alarm(general))
alarm_tamper (Tamper Alarm)
alarm_burglar (Motion Alarm)

I assume that alarm_tamper is raised when moving the device, and that alarm_burglar is raised when moving in front of the device
What are the other 2 - sensor_binary, alarm_general used for?

I only use sensor_binary which reflects the movement in front of the device. The tamper_alarm is the one when the device is phyically moved. Eg vandalism or earthquake. This one and the other ones you mention, I’ dont use at all.
You can give it a try by configuring them properly and testing which item gets updated when. You have to set “report to controller” via HABmin to report all values.

I ended up adding item ZwaveEye1AlarmMotion and linking it to the channel zwave:device:02710de3:node6:alarm_motion
(I also made the presentation read only by setting Text instead of Switch in the sitemap, to prevent changing the state via the GUI)

cat sitemaps/default.sitemap
    Frame label="Fibaro FGMS-001" {
        Text item=ZwaveEye1AlarmMotion
        Text item=ZwaveEye1AlarmTamper

cat items/fibaro.items
Switch ZwaveEye1AlarmMotion         "FIBARO_FGMS-001 Alarm Motion [%s]"  <fire>        (ZwaveEye1) { channel="zwave:device:02710de3:node6:alarm_motion" }
Switch ZwaveEye1AlarmBurglar        "FIBARO_FGMS-001 Alarm Burgler [%s]" <fire>        (ZwaveEye1) { channel="zwave:device:02710de3:node6:alarm_burglar" }
Switch ZwaveEye1AlarmTamper         "FIBARO_FGMS-001 Alarm Tamper [%s]"  <fire>        (ZwaveEye1) { channel="zwave:device:02710de3:node6:alarm_tamper" }
Switch ZwaveEye1SensorBinary        "FIBARO_FGMS-001 Sensor Binary [%s]"               (ZwaveEye1) { channel="zwave:device:02710de3:node6:sensor_binary" }
Switch ZwaveEye1AlarmGeneral        "FIBARO_FGMS-001 Alarm General [%s]" <fire>        (ZwaveEye1) { channel="zwave:device:02710de3:node6:alarm_general" }