[SOLVED] Fibaro Roller Shutter 2 status not updated after switch operations


I have have a simple z-wave installation operated by OpenHAB on a Synology NAS DS412+

An Aeon z-wave stick GEN5 is inserted in the USB of the Synology, z-wave node 1.
Also a Fibaro Roller Shutter 2 is connected, node 3.

Operations through the openhab.app and iPhone app work flawless! Great!

Only… After using the switch attached to the Roller Shutter, the status in OpenHAB is not changed.

What could be the cause of this?


Z-wave binding:

  • version 1.8.1
  • Port: /dev/ACM0
  • Heal time: 3
  • Enable SUC mode: true
  • Enable soft reset: false
  • OpenHAB is master: true

Roller Shutter item definition and binding:
Rollershutter RsKnikarmSchermArnhem “Zonnescherm Arnhem [%d %%]” (Rs) { zwave=“3:command=switch_multilevel,invert_state=false,invert_percent=false” }

All settings done through the habmin app.

The issue is most likely caused by not setting up the associations with the controller.

Thanks Chris, that did the trick.

Opened node 3 in habmin, selected the Association Groups, Controller updates and set node 1 to be a member.

Tested it and it worked !

Great !

I also have a Roller Shutter 2, got it working without problems when sending commands from openHAB to the roller shutter. However, when I close the blinds with the switch wired to the roller shutter, I do not get any updates in openHAB. I’ve added the openHAB Controller to the associations of the roller shutter (in fact, all three associations), but I still don’t get any updates and see nothing in the event log.

Is there anything else needed?