[SOLVED] Fibaro TRV with Aeotec Z-wave stick

I am trying to connect Fibaro TRV with Aeotec Z-wave stick.
I press the action button of the stick one time to add the device (the led blinks blue) and then press the button of the thermostat tribe click (The led of thermostat blinks white), I wait for each other to connect but they don’t!
Any help, please.

What mode is your USB stick in secure/non-secure? if using s2 the manual says you need to enter the security code.
Have you tried with the TRV next to your system with the USB stick installed in the openhab system?
Have you tried a factory reset?

Thank you for replying,

  • Z-Stick Gen5 (Model Number: ZW090)
    This is my z stick model, How can i know if it is in secure/non-secure?
  • Yes, I am using openhab
  • Yes, I made the factory reset for both, but also not connected each other.

Try connecting the stick to openHAB then run the inclusion, see if it makes a difference.
Have you managed to connect any other devices to the stick?
You will have to check the documents for the stick to confirm how you check the mode.

The issue would be the Z-Wave frequency in this case, I cannot mix and match Z-Wave frequency. This would indicate that Fibaro In Wall Dimmer are running on 908.42MHz which is the US frequency.

But the TRV is EU frequency running 868.42MHz which cannot connect to 908.42MHz.