[SOLVED] First installation of OpenHab2. Can't get to dashboard


I am trying to install OpenHab2 on my Ubuntu 18.04.3 LTS. I am following instructions on https://www.openhab.org/docs/installation/linux.html and after successful installation, I go to (this my PC IP address), I am getting “Not Found”. Nothing more, nothing less.
I tried OpenHabian installation and Package Repository Installation. Result was the same.

On the Terminal command “sudo systemctl status openhab2.service” gives me this result (today):
"openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor pre
Active: active (running) since Sat 2019-09-21 23:03:39 EEST; 10h ago
Docs: https://www.openhab.org/docs/

Process: 4291 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited
Main PID: 4446 (java)
Tasks: 93 (limit: 4915)
CGroup: /system.slice/openhab2.service
└─4446 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.con

rugs. 21 23:03:39 giedriaus systemd[1]: Started openHAB 2 - empowering the smart"

I can’t find information related to this case anywhere on the internet, so if anyone has any ideas, please shere it with me!

Are you trying to access openHAB from the same pc as it is installed on?

Yes, ofcourse. I also double checked my IP address. To access OpenHAB, I am using Google Chrome, but I have also tried Firefox - same result.

Not obvious… The question has to be asked.

Have you tried ?

Yes. This one and also localhost:8080

What are the logs telling you?

Thanks that was the next step.

1 Like

Please see “openhab.log” file that I am attaching https://we.tl/t-8TD0usJbxE

I am new, so I can’t attach file directly.

I hope that you will find something, because for me there too many info that I don’t understand.

Even more obvious question.
What version of Java? OH requires Java 8, not 11.

It looks like the 8080 port is already is use in your machine.
Please change the port:

Stop openhab

Edit the file:
Uncomment the line:

And change the port number

Restart openHAB


Thanks a lot, vzorglub! It did the trick!

1 Like