Solved - Frontail install fails with openhabian

@mstormi I have seen another thread that Frontail is failing to install with OH3, and have enabled the debugging in openhabian-config as requested. I have run into the same issue with Frontail not installing.
Is there any other information I could provide to help with this?

Towards the end of the debug output I see this:
E: The repository ‘https://deb.nodesource.com/node_12.x ulyana Release’ does not have a Release file.

Any suggestions as to how to resolve this to get Frontail to successfully install?

My setup is not an upgrade, it is a fresh installation with the following:
Linux Mint 20 as VM (ESXI)
OH3 installed using openhabian 1.6.1-1059(010ded5)
Zulu 11

Here is the full debug output after trying to install Frontail:

openhab@openhab-vlm:/$ sudo openhabian-config
2020-12-24_10:52:03_EST [openHABian] Checking for root privileges… OK
2020-12-24_10:52:03_EST [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2020-12-24_10:52:03_EST [openHABian] openHABian configuration tool version: [openHAB3]v1.6.1-1059(010ded5)
2020-12-24_10:52:03_EST [openHABian] Checking for changes in origin branch openHAB3… cat: /etc/upstream-release: Is a directory
cat: /etc/upstream-release: Is a directory
OK
2020-12-24_10:52:07_EST [openHABian] Switching to branch openHAB3… OK
2020-12-24_10:52:12_EST [openHABian] Updating Linux package information… OK
2020-12-24_10:52:12_EST [openHABian] Installing Frontail prerequsites (NodeJS)…
$ nodejs_setup
2020-12-24_10:52:12_EST [openHABian] Installing NodeJS prerequisites (npm)…
$ apt-get install --yes npm
Reading package lists… Done
Building dependency tree
Reading state information… Done
npm is already the newest version (6.14.4+ds-1ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
OK
2020-12-24_10:52:14_EST [openHABian] Adding required keys to apt…
$ wget -qO /tmp/openhabian.VDHPs https://deb.nodesource.com/gpgkey/nodesource.gpg.key

$ apt-key add /tmp/openhabian.VDHPs
OK
OK
2020-12-24_10:52:14_EST [openHABian] Adding NodeSource repository to apt…
$ apt-get update
Ign:1 http://packages.linuxmint.com ulyana InRelease
Hit:2 http://packages.linuxmint.com ulyana Release
Hit:3 http://security.ubuntu.com/ubuntu focal-security InRelease
Ign:4 https://deb.nodesource.com/node_12.x ulyana InRelease
Err:5 https://deb.nodesource.com/node_12.x ulyana Release
404 Not Found [IP: 209.148.171.32 443]
Hit:7 http://archive.ubuntu.com/ubuntu focal InRelease
Ign:8 http://dl.google.com/linux/chrome-remote-desktop/deb stable InRelease
Hit:9 http://archive.canonical.com/ubuntu focal InRelease
Hit:10 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:11 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:12 http://dl.google.com/linux/chrome-remote-desktop/deb stable Release
Hit:13 http://archive.ubuntu.com/ubuntu focal-backports InRelease
Ign:14 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Get:16 https://dl.bintray.com/openhab/apt-repo2 stable Release [6,051 B]
Reading package lists… Done
E: The repository ‘https://deb.nodesource.com/node_12.x ulyana Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
FAILED (update apt lists)
FAILED
2020-12-24_10:52:37_EST [openHABian] We hope you got what you came for! See you again soon :wink:

Thanks for you help,
Craig

Not really. Your repo definition seems to be broken somehow. And I wonder where that reference to /etc/upstream-release is from. It isn’t in the openHABian code so you must have messed something up, somehow.

I just reverted back to a vm snapshot that only has Linux Mint installed, strictly from the ISO file with only Chrome Remote desktop installed, no other changes from me.
Here is what I have done to install:

  • per Documentation installed Openhabian:

  • enabled debug output in openhabian config file.

  • run openhabian-config, select option 03 to install OH3

  • after install, log into openHab webpage and create user (openhab)

  • reboot system

  • run openhabian-config, select option 20 - Install optional components

  • select option 21 - install logviewer frontail

Installation fails. Same result as the debug info as posted. The only file I have altered is to turn “debug=ON” for openhabian. I have not modified anything else. My installation is a fresh install from Linux Mint, with only Chrome Remote desktop and openhabian being the only software i have added to it.

Either way, Mint is unsupported. Only native Debian and Raspi OS are.

Created new VM with Debian Buster.
No errors.
Solved, Linux Mint was causing error - un-supported OS.