[SOLVED] Get my PI into WIFI

Platform information:

  • Hardware: RaspberryPI 3b+
    *OS: latest OpenHab version
    *openHab version: lastest version
    Issue of the topic:

Hello to the community, I’m relatively new to Openhab and I’m trying to get my PI into the WIFI network. Unfortunately I can’t get into the WIFI via editing the .conf file or via the GUI. When editing the .conf file I get the error that the SSID or the PW are wrong. Both are 100% correct. If I want to change the settings via the mini GUI I get the error after reboot that something is wrong with the DHCPCD. I also get the error that WIFI of the PI is not switched on.
I have looked into the documentation and there is also the way with changing the .conf file described. Unfortunately I don’t know what to do at this point!

Further I would like to mention that my login screen looks different than in the documentation. I don’t get an IP address and further information displayed in a # box.

After I’ve written this I’ll add some pictures with a few minutes delay.

best regards

Kai did you install Openhabian on your pi or another OS and then openhab?

on the Pi.

I think I found the solution to all my problems.

  1. there was no FireMotD installed. How to do this: [SOLVED] OpenHAB 2.3.0-1 Stable: No FireMotD ExportFile detected
    i really don’t know why this wasn’t installed because i installed the latest version of openhab on the sd card.

i dont know how to open a issue on github maybe there is alredy one open?!

  1. my WIFI was turned off because no country was selected Solution:
    sudo raspi-config here set the country, SSID and PW and then reboot.