[SOLVED] Ghost rules from old OH2 beta?


Let me explain what I did and maybe it helps to understand what is happening:

  1. I installed and configured OH2 beta 5
  2. I played with some rules with this beta with the Habmin panel
  3. As they were just tests I tried to delete them from the Habmin panel itself but as I wan’t able I deleted them manually from the files I found on my “openhab2” folder
  4. I checked that there are not any rule inside Habmin panel
  5. Then I moved to the final OH2 release just adding my /conf/ and /userdata/ folder from the beta 5
  6. Everything is working fine
  7. I started using the new Experimental Rules (pretty nice stuff, but still not documented at all)… well, I think this has nothing to do with the problems I’m experimenting
  8. I have just double checked that the test rules are still working but there are any Habmin panel entries nor any rule file inside my /openhab2/

Any idea what’s happening? I think I haven’t correctly deleted the old Habmin rules but now I don’t know where to look for and how to solve the issue without having to start from scratch…

Thank you

I’m replying to myself in case anyone has a similar problem:
After the a whole afternoon looking for the error/bug/config… the problem was located in the Zwave devices pairing. I don’t know why but this defective pairing caused that strange behavior.

In order to solve it, I just reset all the devices and the controller stick and then repaired everything again.

After that everything is back to normal.