[SOLVED] Google Home and OpenHAB Integration OAuth Stuck - Something went wrong. Try later


You may think this topic is an already existing one, and true the subject of it is very similar to many of other topic published in the forum but my case is not akin to others.

I’m trying to integrate to myopenhab using Google Home app from iOS phone, however I’m stuck at the linking where I can’t make it work since it keeps telling me “openHAB is linked” then few seconds later “Something went wrong. Try again”.

How the issue happened: I linked my Google Home iOS app to openHAB as documented and explained. Note that I had no items when the link is done and I faced an error due to wrong items file format. Then while I was exploring the myopenhab.org as part of the troubleshooting, I went into the application tab and removed the Google OAuth and from that moment onward my Google Home app kept stuck on the state where it says “openHAB is linked” then few seconds later “Something went wrong. Try again”.

First things first, See below image showing that currently there is no linked openHAB on Google Home

What I tried:

Note: myopenhab.org is reporting that my server is in online status.

  1. Removed the openHAB third-party signing record from my Gmail account security to ensure removal of the old OAuth link then I tried to relink from Google Home. (didn’t fix the issue, same error).

  2. Simplified my items file and made it clean as simple as the below (didn’t fix the issue, same error):
    Switch MyItem "My Item" [ "Switchable" ] {channel="mqtt:topic:8aa50530:1003"}

  3. Rebooted the openHAB service (didn’t fix the issue, same error)

  4. Checked the openHAB console with log:set debug and log:tail (no errors or related log is reported)

  5. Removed my account from myopenhab.org and recreated it then retried. (didn’t fix the issue, same error)

  6. Finally after spending too much time on troubleshooting the issue, I decided to use another Gmail account on my Google Home app, which finally got me the link added successfully an I can see “My Item” available to control from the App.

In nutshell, seems that my old Gmail account is stuck at a stage where it still thinks there is a link between itself and myopenhab however I’m pretty sure that the link is removed from my Gmail security and myopenhab application section.

Anyone faced similar issue?

Appreciate your help here.

1 Like

Fixed :). To let others benefit from this experience which took me hours and hours to troubleshoot.

It was related to Google Home App on my iPhone. I simply tried the same step of linking Google Home to openHAB on a different Android mobile device and got the OAuth prompt poped and entered myopenhab credentials. Once the openHAB link was established from my Android device, I found the openHAB link was added successfully to my Google Home App on the iPhone as well and all my items appeared and Google OAuth entry on the myopenhab/applications is there now.

1 Like

I had the same issue, but your solution did not work for me. What did work was to first unlink the previous authoirization on Google. You can do that here: https://goo.gle/2N1c1pR

1 Like

Yeah the step you mentioned was the solution for many people. But as I mentioned Juan, in my case it’s very weird that it got stuck although I removed the links from Google Home app and Google links you mentioned which is the OAuth sessions from my GMail account.

The only solution was to reestablish the openHAB link from another mobile phone (in my case I did it using an Android phone) then it worked.