[SOLVED] Google Home Not Switching Items ON/OFF

Platform information:
Hardware: Raspberry Pi 3 B+
OS: Latest Openhabian (as of 29/08/2019)

Please excuse me, I’m not very technical and am still learning about openhab…I have finally gone back to setting up my google home to use my openhab system running on a raspberry pi and realised from trawling the forums that my items file was incorrectly set up. I have now set it up correctly (see below) and have finally been able to get the devices to show in the google home app.

These devices have been assigned to the various rooms in google home, however when i go into each device to switch on/off, it’s not actually switching them on/off. On the app it states it’s on/off when i interact with the on-screen button, but it doesn’t actually do anything IRL. The app doesn’t even realise that a device is on or off. When i try voice control, I’m just met with flashing lights and then a low pitched beep.

Has anyone else had this? Any tips or advice on what might be wrong?

My next step over the weekend is to unlink the service and then factory reset my google home but I doubt that’s going to do much. Like I say I’m not very technical but haven’t been able to see anyone with the same problem.

My very simple items file:

Switch GF_Dining_Light "Dining Room Lamp" <poweroutlet> (GF_Dining, gPower) [ "Switchable" ] {channel="zwave:device:fea5e018:node4"}
Switch GF_Dining_Power "Dining Room Plug" <poweroutlet> (GF_Dining, gPower) [ "Switchable" ] {channel="zwave:device:fea5e018:node5"}
Switch GF_LivingRoom_Light "Living Room Lamp" <poweroutlet> (GF_LivingRoom, gPower) [ "Switchable" ] {channel="zwave:device:fea5e018:node3"}
Switch GF_LivingRoom_Power "Living Room Plug" <poweroutlet> (GF_LivingRoom, gPower) [ "Switchable" ] {channel="zwave:device:fea5e018:node6"}

According to the docs, the tag for lights is [ "Lighting" ] or [ "Switchable" ]
Try changing it to [ "Lighting" ]

I’ll give it a try. Does it matter that they are plug sockets and not smart bulbs (normal lamps plugged into them)? This is why I used the switchable tag, is the Lighting tag a general catch all term to use on most devices?

No not really, there is a specific tag for plug sockets: [ "outlet" ]

I’ve tried the different tags both [ “Lighting” ] and [ “Outlet” ], neither helped the issue, all they did was change the icon but still can’t change their state either by voice or through the app.
I did add two new bulbs (Domitech ones) this evening using the [ “Lighting” ] tag and synced everything with google home again and both bulbs are controllable (although google can’t dim them…another problem for another day).

Okay, so let’s tackle it from here. What app? openHAB? If we can’t control from local UI it’s not going to work from Google Home.

Apologies, the issue is in the google home app. Everything works in openhab (habpanel, paper ui etc) and accessing via cloud connector directly. It’s the google home app where my input (via google home app or voice commands) does not change anything…except for these two new light bulbs i added tonight.

UPDATE: After following people’s advice, I decided to do just a fresh install and rebuild my whole zwave network to see if a fresh start will resolve the issue. I included all my devices again in habmin/paperui and relinked it to my google home. All the devices were added to google home but again none of them would switch on, not even the two domitech bulbs I successfully added and controlled through google home.

And then it hit me, when I added the domitech bulbs (which previously worked) I didn’t ‘include’ them through habmin/paperui, I took my z-stick gen 5 out of my raspberry pi and set the stick into inclusion mode, followed the inclusion process for the bulbs and then plugged the z-stick back in. The bulbs were then in my inbox ready to add. This got me thinking, what if I re-added all my plugs and lights through the z-stick inclusion mode rather than through habmin/paperui?

I tried it with one of the devices that never linked to google home first before adding everything, the device was sat in my inbox ready to be configured, added it and updated my items file. Syncronised with google home again and all of sudden it worked.

I then went through and added each device one by one using the same process and now everything works through google home, voice commands and through the app. So if anybody experiences this same sort of issue and they have multiple inclusion methods, then I highly recommend trying each inclusion method out to see if that resolves it.

If anyone has any questions, feel free to PM me, and thanks again for everyone’s support.