[SOLVED] Google Home now not recognising my items


(Matt T) #1

So, over the last few days I’ve been converting my items that auto-generated from Paper UI and formatting them in my home.items file.

This has involved renaming them all, grouping them, assigning channel’s etc… then deleting the old items from Paper UI. All works now with HABpanel and rules, but since this it has stopped working on Home. I have disconnected and reconnected openHAB and now it doesnt list any of the original items? Where have they gone? And how can i get them back to be recognised by Google? I have made sure it include the [“Lighting”] tag:

Dimmer Hall_Downstairs_Lights “Downstairs Hall Lights”
(gDownstairs_Lights) [“Lighting”] {channel=“zwave:device:205872c7:node7:switch_dimmer”}

Thanks


(Matt T) #3

Diagnosed a bit more…

Seems items in home.items do not show up in PaperUI/HABmin. If i link a new item via HABmin and give it a “Lighting” tag it works in Home.


(Kim Andersen) #4

I´m not sure if it still applies, but there was a need for spaces in the tag square brackets, like this:
[ “Lighting” ]

Give it a try.


(Matt T) #5

Tried, no change.

I think the issue is also related to the fact my items are not appearing in PaperUI or HABmin either.


(B K) #6

Post your item definition using the code fences - the quotation marks shown in your post are wrong and if you use them to define your tag, it will not work.


(Matt T) #7

Found the problem, it was a icon tag which doesnt exist breaking my items file


(Kim Andersen) #8

Hmm, I wonder how an icon tag can do this. Google Home doesnt use the icon tag as far as I can understand.


(Matt T) #9

It appears it had broken all the rules, not just on Google Home (I hadn’t waited for sunset for my rules file to trigger so didn’t realise it had broken it).