[SOLVED] Google TTS voice service on RPI

I am tyring th follow this guide

Is it true that I can’t use the Google TTS service on my Raspberry pi 3?

I get this error when I try to install the add-on

2018-11-26 22:29:13.815 [ERROR] [b.voice.gtts.internal.GoogleCloudAPI] - The architecture is not x86_64 but ARM_32. Only x86_64 platforms are supported.

See this link

If your not sure where to put the .jar file it’s /usr/share/openhab2/addons then restart openhab.

1 Like

i did try to install this jar file.

I get this error in the log

2018-11-26 23:15:10.088 [ERROR] [org.openhab.voice.googletts         ] - bundle org.openhab.voice.googletts: (303)[org.openhab.voice.googletts.internal.GoogleTTSService(313)] : The activate method has thrown an exception

And I am not able to select the Google TTS in the Configuration - system - Voice

when i log in to the console to shows the Google Cloud is active

303 │ Active   │  80 │     │ Google Cloud Text-to-Speech

I did try to reboot, but did not help.

OH 2.3.0 Stable?
If yes: upgrade to 2.4.0 Milestone 6 or latest Snapshot to use this testing jar

Looks like the same exception caused by account/permissions misconfiguration in:

I am using 2.4.0 snapshot

Set the log for this binding to TRACE and post the output.


It works now, thanks.
I did forget to activate billing

Glad your up and running.

Please mark the post as solved by clicking the square box (lower right corner) on the post that provided the solution. Also change the title to include [Solved] at the beginning. e.g. [Solved] Google TTS voice service on RPI.