[SOLVED] GPIO binding stopped working after 2.3.0 update


After updating openhab from 2.2 stable to 2.3.0 stable my GPIO binding to control a Rpi_Relay_Board just stopped working. I’m using a Raspberry Pi3 and just did a apt based update. Prerequisites are still met not sending commands to three GPIO items have simply no reaction. I can still use the command line to export the pins and set them to high/low which controls the relays and that still works. The Logviewer which shows events & openhab main logfile does not show an error, item changes its state but relay does not work.

Any ideas what else could give me a clue why its not working? Is there any more in-depth logs that I could look at or turn on? It’s very hard to debug if logs show nothing. Is anyone else having issues with GPIO on Rpi3 on 2.3.0?

You can turn the GPIO binding to debug or trace logging. Log4j2 Sample Config. I don’t use GPIO but 2.3 has been out for awhile and this is the first posting with a problem so I’m sure there is something that can be done to make it work.

I just did an apt update/upgrade and got this in my logs… Failed installing ‘openhab-binding-gpio’
I revomed GPIO, then re-installed from paperUI and everything seems normal. I noticed the failure log used just “gpio”. During removal and install the log showed “GPIO1”. Not sure if the 1 on the end of gpio caused the issue or not. Here’s the log:

2018-07-20 13:05:32.598 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-gpio': Error restarting bundles:

	Unable to acquire the state change lock for the module: osgi.identity; type="osgi.bundle"; version:Version="0.10.0.oh230"; osgi.identity="org.eclipse.smarthome.model.script.runtime"; singleton:="true" [id=139] STARTED [STARTED]

When installed log was:
Extension ‘binding-gpio1’ has been installed

GPIO is a 1.x version binding so the name of the binding will have a 1 appended. binding-gpio1 is what I would expect.

Thanks for the info Rich,
I’m not using my gpio pins at the moment, so its not a big issue…for now I guess. I did look around and found the below post


Anyone having gpio issues may want to check this post.

In fact a simple reinstall of the GPIO Binding solved the problem.

Hi everyone,
How do you reinstall GPIO binding? from the add-ons options? Because I didn’t see in my openhab dashboard, after openhab-upgrade today, my relay doesn’t work anymore, obviously GPIO-Binding dissapear from openhab.

Make sure Legacy 1.x Add-ons is turned on in Configuration -> System in PaperUI.

1 Like