[Solved] Group Switch does not switch Members

Hi all,

I am setting up my OpenHAB on a RasPI 3 with the RaZberry 2 HAT and mostly Z-Wave components.

I have most of the stuff I need working. Due to some limitations of PaperUI and/or HABmin I decided to define everything in files. After setting up a Samba drive i went at it with the Eclipse Designer tool.

My Problem: I have created a group (gEGLicht) for switches and added two switches to the Group. I also added the Group as a switch to my sitemap. The switches Themselves work properly. But when i try to turn the Group on or off, nothing happens. In the karaf log I also only see, that the group Item was toggled, but the switches stay as they are.

I was under the assupmtion, that if I turn the group Item off, all switches in it should turn off as well.

Here is my items file:

    //Type Identifier "Label" <icon> (group1, group2) ["tag1, "tag2"] {bindigconfig}
    Switch Esszimmer_ZWSwitch1 "Esszimmerlampe" <light> (gEGLicht) ["Switchable"] {channel="zwave:device:b684c393:node7:switch_binary"}
    Switch Wohnzimmer_ZWSwitch1 "Ecklampe" <light> (gEGLicht) ["Switchable"] {channel="zwave:device:b684c393:node6:switch_binary"}
    Group:Switch:OR(ON, OFF) gEGLicht "Licht im Erdgeschoss" <light> (gLicht, gErgdeschoss) ["Switchable"]

And here is my Sitemap

    sitemap myhome label="Zuhause" {
            Frame label="Erdgeschoss"{
                    Switch label="EG Licht" item=gEGLicht
                    Switch label="Tiffany Lampe" item=Esszimmer_ZWSwitch1 icon="light"
                    Switch label="Ecklampe" item=Wohnzimmer_ZWSwitch1 icon="light"

The tags are used for the Hue Emulation binding. I can toggle them via Amazon Echo. Same thing: THe light switches turn on and off, but the group switch does nothong.

If anyone can help, I would be really greateful.

Edit: I have created a switch item that can toggle both Z-Wave Switches by adding both channels to the item’s config, so this is a workaround for now. But I would still like to get the Group solution to work.

I think that the syntax is incorrect (first item= and then label=)

Switch item=gEGLicht label="EG Licht"

Or try without the label= in the sitemap for the switch

Hi Dim.

Thanks for the tip. I removed the Group totally while messing around with the items. Now, after readding it, it works again.

I forst tried adding it to the Sitemap without the label, Just “Switch item=gEGLicht”. That worked. Then I added the label again. First after the item, then before. Both syntaxes work.

It looks like OpenHAB had a hiccup. Unfortunately that cost me half a day and now the configuration looks again exactly as above but it works :frowning:

Thanks for your time!


1 Like

Yup… Actually, (I thought about it again…) placing the item= first shouldn’t have any effect…

Good that it works now :slight_smile: