[SOLVED] Group:Number:AVG not persisted?

Please show us your Item definition and your xxx.persist entry for a group that doesn’t work.

Note that you will need to restart openHAB to pick up most persistence configuration changes (due to essentially being version 1.x legacy service)

I’ve tried variation with and without *

Home_Temperature : strategy = every10Minutes
Home_Humidity* : strategy = every10Minutes
gStore10* : strategy = every10Minutes, restoreOnStartup

I don’t think Item definition is somehow important but here it is

Group:Number:AVG    House_Pressure      "Avg. Pressure [%.1f hPa]"                  <pressure>      (gStatus, gStore10)
Group:Number:AVG    House_Temperature   "Avg. House Temperature [%.1f °C]"          <temperature>   (gStatus, gStore10, Outdoor_Indoor_Graph)

members of the AVG group are stored anyway already because of gStore10 membership
for example

Number  Workroom_Temperature "Workroom [%.1f °C]"   <temperature>  (gStore10, FF_Temperature, House_Temperature)     ["CurrentTemperature"]  { channel = "mqtt:topic:Climate_Workroom:temperature" }

I might try one more restart, sure … just to be on the safe side

I don’t see why. You already know that it will not store the group average with a * appended.

because why not as I haven’t have specific group in persistence, just gStore10* before.
Anyway, it’s not storing desired number even after restart sadly.
2.5.1 snap, influx

Works for me. OH2.4, rrd4j

Group:Number:AVG gIntTemps "Internal temp sensors" <thermometer>


    gIntTemps : strategy = everyChange, everyMinute

REST query response

  "name": "gIntTemps",
  "datapoints": "5",
  "data": [
      "time": 1564002360000,
      "state": "15.5"

I doubt its a factor that your target group is also still a member of gStore10, where recording of it’s value will be rejected.
But maybe persistence only gives us one bite at the apple - I know it is clever enough to avoid duplicates.
Try removing target from other group (and sadly, once more reboot).

is there a quick way how to check rest api?

You’ll need the name of your persistence service, snap? influx?


do i need to install that rest api something in addons?

Yes. It’s called “REST API Docs”. The actual API is always built in, but the “docs” are the interactive play-with-it utility.


Don’t forget the “db” part or it won’t work.

Thinks: what is the name of the .persist file being edited here …

filename is influxdb.persist :wink: and all other persisted items simply works, but not those avg’s

anyway, my rest is taking shit probably
Can’t read swagger JSON from

and… because I’m blind I’ve fixed it by naming those persistence groups correctly as they were Home instead of House … jeez
that dumb feeling

btw it’s not needed to restart OH, it refreshed persistence and worked without restart

We all looked at that and missed it :crazy_face:

That was a momentary bug that appeared somewhere around snapshot build #1638 and was fixed somewhere around build #1640. You just need to upgrade to a newer snapshot.

yeah I did, havent checked rest since ytd night.
btw seen some error in log after update to the latest snap, which havent been there before, it’s worth to report it somewhere?

Always, especially if it is a persistent error (happens every time) and you don’t see that someone else has posted about it.

point me to the right direction please? I’d happily provide some info if wanted as I’m running latest at daily home usage, monitoring logs almost nonstop :smiley:

Search for the error.

If you don’t find a post that talks about that error, open a new thread. In the new thread post your logs showing the error and statements around the error. Describe the context where the error appears (e.g. first boot, when I click on the sitemap, etc) and any other abnormal behavior observed.

Home_Temperature vs. House_Temperature. Please try the real names of the groups.