[SOLVED] Habdroid can NOT access GUI via openhab cloud server

By https://myopenhab.org
I manage to access openhab GUI from habdroid.

However, as I set up my own openhab cloud instance.
By http://my-domain:3000
even though I can remote access by browser & turn on/off hue lamp,

habdroid can NOT connect to cloud server after I put same URL as
in openHAB Remote URL.

I guess the reason might be git version & config.json.
1 Does anybody have some idea which git version we should use to make habdroid work with openhab cloud server instance? Is it a good idea to just use 1.0.2 release version?

2 For config.json, I assume supposedly it is based on config-production.json & config-development.json. However, for the purpose to make habdroid work with openhab cloud server instance, is there some configuration we should pay attention in config.json?

3 Again, myopenhab.org, does anybody have some idea where to look for about their openhab cloud git version & config.json file if possible? That would be a good reference for problem.

Thank you very much.

I believe Habdroid will not work through openHAB Cloud, whether using myopenhab.org or your own instance. This was definitely true as of a couple months ago and I’ve not seen anything on the forum to indicate it has been fixed yet.

By redoing the setup as instructed in the link, habdroid works now.