[SOLVED] Having a "stupid attack" here....re Ecolink motion sensors

I am running “tip of the spear” build on a Pi3.

I have 4 EcoLink motion sensors which have worked for over a year with no problem. (and, Yes - I have replaced the batteries).

Sometime recently (cannot identify exactly when because I’m totally redoing my automation architecture…“film at 11:00” – so this was a relatively minor item initially—no longer minor though…)

The generic item descriptors for these sensors look like this:

Switch	MO_u_01_MOTION_PIR34	"PIR34 KitchenMotionSensor [MAP(en.map):%s]"	<shield>	(gMotion,gKitchen,gMotion_u_01,gKitchen_u_01)		{ channel="zwave:device:8426aca6:node34:sensor_door" }
Switch  MO_u_01_MOTION_PIR34_Alarm "PIR34 KitchenMotion Alarm [%s]"    <shield>  (gMotion,gKitchen,gMotion_u_01,gKitchen_u_01)	 { channel="zwave:device:8426aca6:node34:alarm_general" }
Number	MO_u_01_MOTION_PIR34_Sensor_Battery	"PIR34 Kitchen MotionSensor Battery [%d]"	<energy>	(BatteryLevels)		{ channel="zwave:device:8426aca6:node34:battery-level" }

( I also fiddled with sensor_binary vs sensor_door – there was no change in behavior after a “cold start”.)

The …Alarm and _Sensor_Battery items get triggered (evidenced by the event.log), but the main motion Switch does NOT show up in the event.log via it’s named item. It DOES show up as this:

2017-11-22 16:11:45.949 [vent.ItemStateChangedEvent] - zwave_device_8426aca6_node34_sensor_door changed from CLOSED to OPEN
2017-11-22 16:12:38.156 [vent.ItemStateChangedEvent] - MO_u_01_MOTION_PIR34_Alarm changed from NULL to ON
2017-11-22 16:12:47.774 [vent.ItemStateChangedEvent] - MO_u_01_MOTION_PIR34_Sensor_Battery changed from NULL to 100

Anyone have a clue ???

Answer is that the required itemtype for these sensors (when using an .items file) has reverted to Contact from Switch. It was Contact for a long time, then changed to Switch (possibly with OH2 release – quite a while back though) and has now changed back to Contact.