[SOLVED] Having trouble with GE ZWave 26931/ZW4006 In-Wall Smart Motion Switch

I have the subject switch, database entry is here. When I try to enable association mode, it never takes. I’ve uploaded the debug log entries for changing “Association Mode” from Disabled to Enabled. Also, I only ever receive events from the switch_binary and switch_binary1 channels - but I believe this may be because I can’t enable the association mode.

openhab.log (16.1 KB)

Any insights would be appreciated.


1 Like


Also, here’s the ZWave Log Viewer output (cut and pasted - is there a better way to include this?):

09:44:05.971	2	CONFIGURATION UPDATE config_4_1 1 (BigDecimal)
					01 0C 00 13 02 05 70 04 04 01 01 25 AE 1C
09:44:06.006		RX ACK 0 /128
09:44:06.017	2	RX RES SendData 174 ACCEPTED BY CONTROLLER 0 /128
					01 04 01 13 01 E8
09:44:06.032	2	RX REQ SendData 174 ACK RECEIVED from device in 33ms 0 /128
					01 05 00 13 AE 00 47
					01 0A 00 13 02 03 70 05 04 25 AF 1C
09:44:06.094		RX ACK 0 /128
09:44:06.103	2	RX RES SendData 175 ACCEPTED BY CONTROLLER 0 /128
					01 04 01 13 01 E8
09:44:06.154	2	RX REQ SendData 175 ACK RECEIVED from device in 66ms 0 /128
					01 05 00 13 AF 00 46
09:44:06.167	2	RX REQ ApplicationCommandHandler CONFIGURATION_REPORT PARAM_4 size=1  1 /128
					01 0B 00 04 00 02 05 70 06 04 01 00 84


What version of the binding are you using? If it’s not the absolute latest from within the past day, then please update to the latest snapshot.

You don’t really say what your problem is - is not being able to set this parameter the problem, or are you trying to change this parameter to solve something else (I guess so)? I’m not sure what parameter 4 does - “Association Mode” doesn’t really mean anything - do you know what does this actually does?

From the log, it looks like the binding is sending the correct data, just the value being read back doesn’t change. Maybe this is normal for this parameter (it’s not uncommon to have write only parameters that always read back a fixed value)…

I normally just paste them in as images - the image of what you think is wrong, supported by an unfiltered log (as you also provided) is probably a good combination.

Thanks for you response, Chris.

I’m using the 2.4.0 version of the binding. Will a snapshot version of the binding work with 2.4.0 or would I need to move all of OH to the latest snapshot?

Yeah, because I’m not quite sure what the problem is. I can only ever receive events from the switch_binary and switch_binary1 channels. I never see the motion events (all of the other channels - sensor_binary, alarm_burglar and alarm_burglar2 - never send events). The documentation doesn’t say much about the ZWave support and isn’t clear on any of this:

• This device supports Association Command Class (3 Groups)
• Association Group 1 supports Lifeline, Binary Switch Report
• Association Group 2 supports Basic Set and is controlled with the local load
• Association Group 3 supports Basic Set and is controlled by pressing the On or Off button
• Each Association Group supports 5 total nodes

So maybe I shouldn’t expect to see anything but the switch_binary and switch_binary1 events since the documentation doesn’t mention anything about the motion sensors or sensor reports.

I’m guessing that it enables the Group 2 and Group 3 association groups. I don’t need those, but was curious if that would actually trigger getting the motion events.

How I’m using this switch now I don’t really need the motion events, but it will determine if I use this light switch for other things.


Yes - there aren’t too many changes between the two - updated database, and a few important fixes.

So just to be clear - do you mean that if you look in the log, there is nothing received, or, do you mean that the channels don’t update?

It’s quite possible the database needs adjusting, so please make sure that there are no frames showing as being received in the log.

Firstly, the lifeline normally receives all reports that are of interest to a controller - what’s interesting is that this list doesn’t mention notifications (or alarms).

That’s quite possible - this device might just output the switch channels - can you “separate” motion from the state of the switch, or does every time the motion sensor detects motion, it turns on the switch?

The only thing that goes against this is that in the database there is an ALARM command class, so I would actually expect motion to be reported. It’s also possible that someone manually entered that, and it’s not really supported!

Can you supply the XML for this node (in the userdata/zwave folder).

Maybe - that’s a bit strange though as they are (normally) implicitly enabled when you add nodes. ie no nodes = disabled, if you put nodes into those groups, then it is enabled and will report to those nodes.

I guess I mean the channels don’t update. When I set the logging to debug, there definitely seems to be some alarm data. I’ve attached a debug log of when motion activates the light switch: openhab.log (11.3 KB). And here’s the ZWave Log Viewer output:

In the mode I have it, Occupancy mode, it will turn the light on with motion and off with no motion after a certain amount of time:

Occupancy – Light turns on automatically with motion and off automatically without motion
Vacancy – Light turns on manually and off automatically without motion
Manual – Light only turns on and off manually

Here’s the XML for the node: node_2.xml (21.5 KB)


Perfect - thanks. This is what I was expecting to see, and it means that the database is not set correctly. I will do an update to fix this (it just needs the channel naming correctly).

I tried the updated XML for the device and I still wasn’t getting the events. I tried removing the type=BURGLAR from the alarm_motion channel, but that didn’t help. So then I tried changing the alarm_burglar2 entry to:

      <channel id="alarm_motion2" typeId="alarm_motion">
        <label>Motion Alarm 2</label>
          <property name="binding:*:OnOffType">COMMAND_CLASS_ALARM:2,COMMAND_CLASS_BASIC:2</property>

With that change, I’m now receiving the motion events for this switch.


@ohtl Tom, exactly what did you update and where to band-aid the issue. I’m using both the 26931 and 26932 switches and motion detection stopped after the upgrade. I’ve even moved to 2.5M1 with no resolve.

@chris Chris, should your updates have made 2.5M1?

At this point all I see is the state changing to OFF but never an ON


If you want to pick up database changes you need to delete the thing and readd it (don’t exclude!).
Also make sure the correct association group is set to your controller.

Okay, that took care of the 26931/ZW4006 In-Wall Smart Motion Switch. Thanks!! My focus has been on the 26932/26933/ZW3008 In-Wall Smart Motion Dimmer of which I have excluded as well as deleted. As this thread clearly referenced the 26931 I am confident the 26932 needs updated as well.

Do you need any log files to validate the updates required for the 26932?