(solved) Help needed i go crazy (new install)

  • Platform information:
    • Hardware: intel 3805U 8GB ram
    • OS: mx linux 18.3
    • Java Runtime Environment: openjdk version “1.8.0_212”
    • openHAB version: No idea latest git and updated
  • Issue of the topic: installed but nothing works
  • Please post configurations : where-how
    • Items configuration
  • Sitemap configuration
  • Rules code related to the issue
  • Services configuration related to the issue
  • If logs where generated please post these here using code fences:
    login browser
    gives An error occurred

In terminal
$ sudo openhab-cli stop
[sudo] password for jan:

A systemd service configuration exists…
Use ‘sudo /bin/systemctl stop openhab2.service’ to stop an openHAB service
Stopping any instance of openHAB…
$ sudo /bin/systemctl stop openhab2.service
Failed to stop openhab2.service: Unknown unit: openhab2.service
See system logs and ‘systemctl status openhab2.service’ for details.
Failed to get load state of openhab2.service: No such property ‘LoadState’

So HELP what to do and how

ps aux | grep openhab

then kill the process kill -9 ***

*** = PID

Actually sudo kill -9 ***

OK killed it :slight_smile: and how to test the install as i assume it should have worked.

I am not familiar with mx linux but notice is is a desktop OS.
Do they use systemd or SysV init? That could explain why the systemd command did not work.

It is debian 9 based but the use SysV init

Any particular reason you chose this OS?

It worked much programs made working, good support and debian based, ubuntu dint run good on this machine.
I have a raspberrypi 3 b+ but this laptop is using less power :slight_smile:

Debian with no desktop selected should run fine. I have OpenHABian running on a Debian VM on my Windows laptop for quick testing.

My main OH server is a Raspberry Pi 3B+ with a USB SSD drive, running Raspbian Lite.

Yes it works i can get to it `
Now to see how to get the data in it :wink:

1 Like