[SOLVED] Help: Update from 2.2 to 2.3 stuck

Tags: #<Tag:0x00007f616ea81f98>

Hey,

how long does it take to update from 2.2 to 2.3 ?

the Update hangs on 50% for 15 min. now, nothing is happening …

what should i do ? aaaaahhhhhhh ( i made a backup from Openhab before - no SDCard Backup )

i updated from openhabian config console on my Raspb.

sudo openhabian-config

Thanks!

I use a RPI B w/SD card for testing and it sometimes hangs but 15 min seems a bit long. I would give it another 15 min or so.

You have a backup, so installing a fresh image may be an option. Note, if you’ve never tested that your backup works, make this the last option.:wink:

This is how i’ve done my Backup:

sudo systemctl stop openhab2

TIMESTAMP=`date +%Y%m%d_%H%M%S`;

sudo mkdir /backup
sudo mkdir /backup/openhab2-backup-$TIMESTAMP
sudo cp -arv /etc/openhab2 /backup/openhab2-backup-$TIMESTAMP/conf
sudo cp -arv /var/lib/openhab2 /backup/openhab2-backup-$TIMESTAMP/userdata

the Backup folder is on my Mac - i dont have a full SD-Card Backup - next time i will do that too :frowning:

i will wait a bit longer and hope it will complete - but for now i am waiting since 17:25 ( 5:25 pm ) - its close to 1 hour now :frowning:

how is the process of bringing it back to work ? never done that :unamused:

EDIT:
i also have Grafana and InfluxDB running - no backups made here :confounded:

This is how I restore from backup after placing the backup in /var/lib/openhab2/backups file then:

sudo systemctl stop openhab2.service
openhab-cli restore /path/to/zipped/backup (var/lib/openhab2/backups)
sudo systemctl start openhab2.service

Do you have another RPI and SD card to test with? If so, use it to test with before pulling the plug on the other.

no i dont have another one :frowning:
I also have Grafana and InfluxDB running, without a backup so far :frowning: will this take effect here, no , right ?

i’ll do a complete SDCard Backup after all :frowning:

I honestly don’t know, I use rrd4j for data and the backup works with it. Hopefully it will work with Grafana and InfluxDB.:crossed_fingers:

Before moving to an SSD hard drive I would make an image copy every few months just encase. But never needed to use them as the back and restore works with my setup.

Ok hope so too :frowning:

what do i need to do, if i dont have a Backup-ZIP-File
i got 2 folders in /backup (Config & Userdata)

One thing I noticed with your backup, posted above, the directory you created was named backup. After installing a fresh image check to see if /var/lib/openhab2/backups was automatically created. This is were you will want to place your backup. Note the directory is backups not backup.

If not auto created you can use openhab-cli backup command and it will be created. Just replace that backup with yours.

can i do this now, although the update stuck on 50% ?

Never tried with it stuck but to restore a backup OH needs to be stopped.

Can you access another ssh terminal? If so, you may be able to kill the process that hanging. Not sure what the result would be since its trying to install??

i think i got it fixed - OMG

i closed the 50% update window after 1,5 h waiting and in a new shell back to the config tool

i clicked again on “openHAB Stable” and got this message (1) and run the command manually - after that i clicked “n” (2)

Then i saw something is happening in the LOG again - wohooo - after some seconds i got this:

02

i did a “sudo reboot” and now it looks like its working again - all my Bindings are gone - but i think i found all and reinstalled them

i think its done now … hope so

What was your tension level when the mouse went click?:smile:

That’s good to hear your back up and running. It’s also good to know that closing the window before it’s finished is OK.

Thanks

BLOODY NIGHTMARE :skull_and_crossbones::skull::japanese_ogre:

1 Like