[SOLVED] High CPU Usage

Hello everyone,
I am trying to troubleshoot high cpu usage.
I am running openhab for some time, but recently I tried updating to 2.4 milestone 5 (I believe 5 was the latest before 2.5) which caused constant full cpu usage.
So I reverted back to the milestone 4 which solved it. So I told myself lets wait for stable.
However then 2.5 came out and I updated the high cpu issue came back.
I am running OH in virtual machine on vmware cluster. (4GB Ram, 2CPU cores)
Cpu type doesn’t have affect on this as I can migrate from my xeon d-2123 to i7-7567U.
OS is Ubuntu 18.04.3.
Only thing that I found in the logs is zwave devices are being disconnected, but I guess that is because no resources left to handle the remote usb client.
When I use htop or different think to see which java thread is causing it I see 4-8 threads causing similar load, but always together full cpu.
I tried reinstalling OH, tried using different java, but nothing helped.
Thank you for any advice

Also I reduced number of rules to 3, to see if it a compiling issue maybe. Also using influx as db

Forum search?

Thank you.
I missed this one. as I was really looking for “high cpu usage” and also this one has the bindings restart, which was not my case.
Also I uninstalled mail bindings as I was not using it, but it was still stuck there somehow.
Thank you again and next time I look more.