[Solved[ Homematic system variables - thing gateway-extras not found

Tags: #<Tag:0x00007f616e63d7e8>

Hi!
In order to reload newly created system variables from homematic (Raspberrymatic 3.49.17.20200131) - in the past have deleted the gateway-extras thing. A new search in the inbox of paper-UI and I found the gateway-extras thing with all the new variables. A piece of cake if you like.
Since yesterday paper-UI is not finding the gateway-extras thing.
What I did to fix it:

  • restart/reboot homematic and openhab (2.5.1)

  • uninstalled the homematic binding and re-installed

  • tried to create it manually

  • also the “physical” things - specially the homematic IP - are not working properly

Any idea what else I could do?
Where do I find more actual snapshots of the binding?
Thanks Georg

https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/addons/bundles/org.openhab.binding.homematic/

Hi,

I still don’t know what happens:

  • I did a re-install of openhabian version 1.5 - also here the gateway thing is not detected.

  • I changed back to Raspberrymatic 3.49.17.20191225 - which was working before - also the gateway thing is not detected.

  • Still do not know the difference of the homematic.thing (manually created) and the detected eQ3-HmIP-CCU3-App.

Thanks for any hint.
Georg

@MHerbst, @gerrieg
Hi Martin, Gerd!
any recommendations from your end - it was running for 2 Years without any problems - but now it looks weird.
Thanks for any help
Georg

Hi Georg,

I am not sure whether I understand everything correctly. How did you configure your Homematic things? Everything in text files or via Paper UI? Do you see any error messages in openhab.log?

I don’t think that it is a problem with the Raspberrymatic version, because I am also using the latest version without any problems. Maybe something went wrong when you deleted the GATEWAY-EXTRAS and the internal openHAB JSONDB contains some remains that now causing some problems.

You could try the following: stop openhab, make a backup of the userdata/jsondb folder. Remove everything from the jsondb folder and start openhab again. You should now have a clean installation and you can test whether the GATEWAY-EXTRAS can be used now. If you don’t want to clean everything you could edit the .json files in jsondb and remove everything that from GATEWAY-EXTRAS.

Hi Martin,
originally I had a homematic.things file with just the bridge - the homematic things were discovered by paperUI, but for the items I had homematic.items file. This worked for the last 2 years. I had setup new Systemvariables at Homematic - so I deleted the gateway_extras thing, but I could not restore it via the inbox.
I decided to make brand new installation of openhabian 1.5 and installed only the homematic binding in the actual version (2.5.2.202002141310). Deleted the homematic.thing file and try to recover all homematic things via paperUI. First of all I get the eQ3-HmIP-CCU3-App - 192.168.XXX.XX thing - as soon as I add the thing - further Homematic things were discovered, but not the gateway-extras thing.
So I am lost. Will attach the trace file for the homematic binding.
Thanks for help
Georg
homematictrace.txt (86.4 KB)

Unfortunately your log file ends where it gets interesting. I have never seen this exception before and this is really strange.
Can you start openHAB with no iterms and things files and try to add the bridge in Paper UI. Then do another scan and post the complete openhab.log. It would be even better if you could try it with only the Homematic binding installed.

Maybe there is some interference with another binding,

Thanks Martin,
I deleted most of the conf-files (things, items …).
I deleted the jsondb-files.
Restartet openhab2.service - found eQ3-HmIP-CCU3-App - 192.168.XXX.XX thing - which I added a thing. Further Homematic things were detected.
The homematic binding is the only binding installed.
I attache the log files
202002102020homematictrace.txt (216.1 KB)
events.log (751.6 KB)

the openhab.log ist > 3MB and i cannot upload it.
I hope you find what you need.
Thanks for your help
Georg

@MHerbst
Hello Martin,
Was the information provided sufficient - or do I need to collect more information?
Thanks in advance
Georg

Hi @GeorgJ,

thanks for the log. I think, I have found the reason. There is a NullPointerException while creating a device. Probably this exception prevents the creation of the GATEWAY-EXTRAS thing.
I am fearing that there could be problems with the Wired components.

What kind of device is OEQ1530260? It seems that this device causes the problem.

Thanks Martin,
this is HMW-IO-12-Sw14-DR Homematic Wired RS485 I/O-Modul 12 Eingänge 14 Ausgänge - which I had to replace over the weekend, since it showed faulty results.
I just rescanned the Homematic devices and the gateway-extra thing was rediscovered.
Could I have seen the error (NullPointerException) in the log - Is there a chance to mark this error und make it more transparent?- also from the error message in Homematic, there was no clear indication to that device.
Thanks again for the work
Georg

This can explain the problems. What I can see from the log the device was not correctly detected and did not reply correctly to a request.

Could I have seen the error (NullPointerException) in the log - Is there a chance to mark this error und make it more transparent?

No really. These kind of exceptions should never happen :-). Especially this location was very strange. You can see these exception in the openhab.log even if the log level is set to INFO or higher. The LogRead add-on (https://www.openhab.org/addons/bindings/logreader/) could help. But I did not try it yet.

Thanks Martin,
I have set the thread to solved.
Kind regards
Georg