[SOLVED] How to add a GitHub binding to Openhab Addons folder

Hello All,

I am quite new to openhab and still keep warming up. What I am not being able to do is adding a GitHub binding to my Openhab so that I can see it on my Bindings list on PaperUI.

I tried to add this binding shown as follows :

I tried all each following actions to make it work but no use :

I cloned the repository files , as folder , as .zip and also convert it as .Jar (because I can not download it as .Jar file ) :
jar cf org.openhab.binding.broadlink.jar org.openhab.binding.broadlink

and added it to my openhab/addons/ folder , and even added binding in addons.cfg file as binding = broadlink.

Still can’t see any binding added in Paper UI.

I can’t understand what I’m missing!



What you downloaded is a zip files containing the repository file. Source code and all. There is no jar file in there. Converting a zip file to a jar file does not make a jar file. Just like putting a Jedi costume on does not make you a Jedi. The repo files need to be compiled into a jar file that the openHAB java machine can read.

I don’t know how to do that.
I don’t use the broadlink binding.

Here is a link:


If you want to build a .jar, you need to compile the code you “cloned” from github. For that you Need a full IDE installatin as decribed in here.
Having done all that you could use a maven command to do the build (in other words compile) which would give you the .jar.

1 Like

Nice analogy.:+1::smile:


Sorry for off-topic but this is something you have to put in your profile signature. :smiley:

1 Like

Lol. But I felt the Force


Not really. You can build with just Maven.
But a full IDE is nice if you’re going to be doing much code editing.

1 Like

Now got stuck on Eclipse installation (( . Trying to find a solution for this on Eclipse Forums.

I had some problems installing the latest Eclipse Version on macOS.

In the Eclipse Installer, you can choose an older version, lik 2018-09. I had no succes with newer version, but 2018-09 installed fine for me.


1 Like

What did you select to install? Did you follow the steps : https://www.openhab.org/docs/developer/development/ide.html

1 Like

Probably because of my firewall settings :roll_eyes:. Now tried again with a differen internet and no issues with setting up IDE.

In addition to , I found a working Broadlink binding (.Jar) and could be able to directly add the .jar file to my /Addons/ folder and worked perfectly!!


Could you post a link to it, please?