[Solved]How to configure RRD4J.CFG

How should I conigure my RRD4J persistance service in order to store only the needed values in a correct way?
I’m using OH2
I want to save price-data in 5 minute steps over a period of 4 weeks. The minimum price is 0, the maximum 3.
That is what I think is correct:

PriceLogger.archives=LAST,.5,5, 8064
PriceLogger.items=Price1, Price2, Price3, Price4

I like to plot the actual values of each price-reading, so I’m using a GAUGE. The heartbeat is 300 secs or 5 minutes. Minimum price 0 Maximum price 3 and I take a reading every minute (60 seconds).
The archive is setup to take the last value of 5 (steps) readings and will keep 8064 readings (28 days every 5 minutes). Not sure about the .5 for “xff”.
And I’m logging the Items Price1, Price2,…

Am I on a good track?
As of now a persistence service is running, but I can’t see that my settings are even used???
For example the file …/userdata/persistence/rrd4j/Price1.rrd contains amongst all those unreadable characters only “AVERAGE” but not “LAST” as I would suspect.

Additional question:
Where would I use the name “PriceLogger”? As of now I can’t see where I should use it.

I found some more explantions:

First of all, if the setup of the RRD4J database needs to be changed, it looks to me as if the old database has to be deleted in order to let the new config to be used.

I needed to change and clarify my setup.
I’m looking at pricedata which can change every minute, so the .def part was OK. Only a heartbeat of 5 times the step-duration seemed a bit to much, so I change it to 90 seconds


Saving all data every minute for the complete time (up to 4 weeks) however is not needed. I’ll be looking at data for each minute when looking for the last day. When looking at data for a week 5 minute-steps are OK, when looking at for 4weeks 15 minute steps are OK. Hence the number of steps can be calculated. So my archives are configured like:


When trying to display a specific timeframe, the best archive is used automatically.