[SOLVED] How to configure sound on Archlinux family disto?


2 days and I stil can’t make sound works. So do you know how to configure it on linux ? any up-to-date doc or tutorial I can follow ?


Platform information:
    Hardware: Ryzen 3700X/64Go RAM/SSD 500Go
    OS: Linux Manjaro
    Java Runtime Environment: OpenJDK 64-Bit 1.8.0_242
    openHAB version: 2.5.3
Issue of the topic: No sound with System speaker (every thing is ok with “Web audio” but it's not what I want unfortunately)

Please post configurations (if applicable):
    Items configuration related to the issue NA
    Sitemap configuration related to the issue NA
    Rules code related to the issue NA (I think)
    Services configuration related to the issue NA
If logs where generated please post these here using code fences: NA

That is an Arch Linux question best asked on their forum.
Arch expects you to configure every thing manually for greatest flexibility.

I have never run ArchLinux, I’ve always been a CentOS, Red Hat, Fedora kind of guy before I met OpenHAB. Then I wanted to run a Deb based distro. Had loaded Debian at least once before and loaded Debian 9 for my first crack at a dedicated OpenHAB box. The forum is littered with my trials trying to get sound working. About 6 months ago, I wiped everything and started with a fresh install of Mint Linux and the sound just works…

I’ve not used Manjaro before but the ArchWiki is usually quite good:


If you are running a headless server are you sure you have the volume turned up? By default sound output is muted (N.B. you need the alsa-utils package installed to use these commands):



Thanks everybody for your answers. But I’m pretty sure the problem comes from OpenHAB installed on ArchLinux, more precisely a configuration to do because my distro is well configured. I have sound with my headphones and speakers. If I select “Web Audio” in OpenHAB I have soud, but if I select “System speakers” it doesn’t.

I even develop a Java class that looks like OpenHAB JavaSound code. And It works perfectly. So I suspect a configuration somewhere in OpenHAB that mutes or turns down volume. I tried to set volume in rule and console, but I had exception.

Right now, no luck at all :frowning:

So my third day trying :slight_smile:

Thanks again and have a good day

Did you try uninstalling OpenHAB to see if the issue was resolved?
What instructions did you use to install OpenHAB? There are no official packages for Arch.

Nope, I didn’t uninstalled. But … My first install was the AUR Openhab2.
As it doesn’t work, I stopped and disabled the service and I tried a manual install (in a new folder).
I have the same problem.
But you were right, I will also ask AUR package maintainer.

Don’t know if this will help but maybe clue


That install is supported by the ArchLinux user who created the package then.
AUR is the ArchLinux User Repository.
Have you asked on the Arch support forum?

Thanks, I’ve already red this post. It helped in that mp3 doesn’t work at all (I used to try with doorbell.mp3). So now I use wav file.

Yes I did

1 Like