[SOLVED] How to disable embedded MQTT broker in Paper UI (Openhab 2.4)

Hi all, I’m running openhabian latest stable edition ( 2.4).
I’ve recently expanded to include MQTT, via the openhabian-config - installed mosquitto server.
I have this server up and working correctly, tested through various terminals on different machines.
I also have been able to install the MQTT binding, and a manual broker that is configured successfully, with a thing created and displaying messages correctly in habpanel when the topic updates.

My challenge is disabling the enabled broker.
My log is full of errors of this

2019-01-18 15:28:13.993 [WARN ] [r.internal.EmbeddedBrokerServiceImpl] - Embedded broker offline
org.eclipse.paho.client.mqttv3.MqttException: Unable to connect to server
	at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start(TCPNetworkModule.java:94) ~[265:org.eclipse.paho.client.mqttv3:1.2.0]
	at org.eclipse.paho.client.mqttv3.internal.SSLNetworkModule.start(SSLNetworkModule.java:103) ~[265:org.eclipse.paho.client.mqttv3:1.2.0]
	at org.eclipse.paho.client.mqttv3.internal.ClientComms$ConnectBG.run(ClientComms.java:701) [265:org.eclipse.paho.client.mqttv3:1.2.0]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.net.ConnectException: Connection refused (Connection refused)
	at java.net.PlainSocketImpl.socketConnect(Native Method) ~[?:?]
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ~[?:?]
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:?]
	at java.net.Socket.connect(Socket.java:589) ~[?:?]
	at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start(TCPNetworkModule.java:80) ~[?:?]

I have tried removing the auto-installed embedded broker, removed the binding, tried to clear the cache (but for some reason sudo openhab-cli stop states it’s going to stop the program, but clean-cache says that the program is still running. I restarted the RPi3B a couple times, then re-installed the binding, and specifically did not install the auto-discovered embedded binding (but it keeps on showing up in the inbox).

The errors keep on coming up in the log for the embedded broker. (the correct manual broker was successful in the logs, way up, and continues to function correctly).

Is there a way to remove the embedded broker?


Does it show as installed in Paper UI > Add-ons > Misc > Embedded MQTT Broker? (So does it say “Uninstall” there?)

forehead smack
Yep, that was it.
I had removed it often enough before when I was trying to get MQTT working in the first place, then after the final install this was forgotten.