[SOLVED] How to get OpenHAB 3.0 to work

  • Platform information:
    • Hardware: Intel
    • OS: Windows
    • Java Runtime Environment: Java 8
    • openHAB version: 3.0

I want to try out OpenHAB 3.0. I downloaded all needed files but it seems OH did not start. No OH specific commands available after starting console. Is it to early to test it?

Error messages at console:

openhab> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-runtime-base; type=karaf.feature; version="[3.0.0.SNAPSHOT,3.0.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-runtime-base)(type=karaf.feature)(version>=3.0.0.SNAPSHOT)(version<=3.0.0.SNAPSHOT))" [caused by: Unable to resolve openhab-runtime-base/3.0.0.SNAPSHOT: missing requirement [openhab-runtime-base/3.0.0.SNAPSHOT] osgi.identity; osgi.identity=openhab-core-io-rest-voice; type=karaf.feature [caused by: Unable to resolve openhab-core-io-rest-voice/3.0.0.SNAPSHOT: missing requirement [openhab-core-io-rest-voice/3.0.0.SNAPSHOT] osgi.identity; osgi.identity=openhab-core-base; type=karaf.feature [caused by: Unable to resolve openhab-core-base/3.0.0.SNAPSHOT: missing requirement [openhab-core-base/3.0.0.SNAPSHOT] osgi.identity; osgi.identity=org.openhab.core.config.core; type=osgi.bundle; version="[,]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.core.config.core/ missing requirement [org.openhab.core.config.core/] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.openhab.core.net)(version>=3.0.0)(!(version>=4.0.0)))" [caused by: Unable to resolve org.openhab.core/ missing requirement [org.openhab.core/] osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"]]]]]
        at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
        at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
        at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
        at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
        at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
        at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)

I have a quote from Kai:
As a result of those activities, the current 3.0.0 code base is not yet usable, so please refrain from trying out any 3.0.0-SNAPSHOT distro for the moment. It anyhow [does not include any add-ons ](https://github.com/openhab/openhab-addons/pull/6701), so it is rather pointless.
Full post Here

The question is: what are you trying to do, 3.0 is NOT even close to be released!

I know. But i want to learn the new rules engine and stay on OH 2.5.1 as productive.

Why don’t you use it in 2.5.1? That isif you are talking about the one that you can install via PaperUI as the( experimental) Rule Engine.

The short answer is. Only if you have development experience with openHAB core you should do something with 3.0. For everybody else don’t do anything with 3.0 until there has been an announcement you can try it.

The new rule engine is already part of openHAB 2.5.


And if the op still can’t resist, error log gives the reason : Java 11 is needed :slight_smile:

1 Like

And if @HomeAutomation still cannot resist, Snapshot issues are to be reported on GitHub, not here.

java 11 was the trick, thanks a lot

But keep in mind, it is not meant to be ready for testing, so don’t expect any suport if you face issues or have questions.

Pay close attention to Hilbrand’s posting. You can use the new rules engine on 2.5. See [beta testers wanted!] Jython addon w/ helper libraries (requires OH 2.5.x) to get started with Python. The UI replacement for PaperUI is not yet implemented I believe.

1 Like