[SOLVED] How to identify "Queue Full" issue with Z-Wave?

Hello @chris, I have updated to version 1607 and currently getting nearly each day an error “queue full”, which results in all following events not to be processed (= my whole zwave part is no longer working). My debug log from today is available at https://1drv.ms/u/s!Apfsw6uW4hjmg8VJgcqojb6UnUr2Vw . Since 18:57:49.540 the queue is growing. I cannot identify, what the initial wrong point is. All other entries on this site having had similar or same effect do not really show me up what I can do. Can you please help me to identify the issue? Many thanks! Siggi

Some more data: I’m running OpenHAB on a RasPi with Openhabian.
I have already made a software reset on my zwave controller and also I deleted and added it newly.
Like in an other blog this seems to happen in relation with a discover. And I get two things (43 and 45) in the inbox, which I cannot identify. Maybe they as initial events for the full queue. But I have no clue what the system (the controller or the binding) has found here. I have added both things, remooved them in Habmin from controller and deleted them again, but they appear again and again withount identifying them.
All my other zwave things are online and - as far as I have tested - are all running well. Currently I restart my system a few times per day.

Update 10.6.19, 14:51: This morning the two things 43 and 45 no longer appear in inbox after a restart last night. But the queue again is full after I did a thing discovery in the morning. So at 9:33 you see a second time the queue getting filled. I have replaced the openhab.log with the new version from today.

Hello, what is this queue, which is full? Which component of my system has tp process the queue? Would it be possible to delete the first entry in the queue if the number of entries exceeds e.g. 100, so the processing of the queue could go on then?

It’s the ZWave receive queue.

The ZWave binding.

I’ve not looked at your logs, but the issue is very likely NOT the queue being full. The queue is quite large, and normally if it fills up it is caused by something else so deleting messages out of the queue won’t help.

@chris I took a quick look at the log. There are two cases where the queue filled up. In both cases, it seems to coincide with the second invocation of discovery. One at 18:57:49 and the other at 09:33:23.

Edit: To be a bit more clear. Those times are when the queue starts to fill. After each of those times, the queue size grows on each received message.

Yes - this is what I’ve seen in other logs. Unfortunately I don’t know what the root cause is - ultimately it stops reading incoming messages so something is getting stuck somewhere.

This is something I’ve been looking at (there’s another thread on that somewhere) but it’s not obvious and I’ll need to add more trace logging.

Can you identify in the log file which kind of entry is the first in the queue? It happens each time I run a Discovery. So is it possibly something to add a new entry in the controller? Even there currently no new thing should be found … Or to update the controller?

By the way: I have removed my controller and discovered it again some days ago (and removed the xml file). Also I have done a software reset of the controller. Nevertheless it does not show any data in the properties screen except the nodes of neighbors. But the normal events (not discovery) are all processed well … (it is a Zwave.Me controller stick)network_f8886ed0__node_1.xml (2.0 KB)

No, but I don’t see that this matters. We know when the queue starts to fill up. As I said earlier though this doesn’t really help as we need to find what is causing the code to hang.

This code has not changed for a long time, so I’m surprised that this has recently started happening.

I don’t understand what you mean by this?

Just to link this to another thread on this issue -:

I will remove this feature from the binding - I’m not sure what has changed in OH to break this :frowning: .

1 Like

Hi @chris, I was off some days. Today I first started a discovery and got increasing queue length. I installed then new snapshot #1639 and with this I was no longer able to reproduce the increasing queue.

1 Like