[SOLVED] HS220 only has a brightness channel, setting to "0" does not work

I’ve upgraded to OpenHab 2.4 which has HS220 support! However, I’m wondering if the support for it was actually tested :slight_smile: Only a brightness channel is exposed and while setting the brightness to a non-zero value does indeed turn the light on, setting the brightness to β€œ0” does not turn the light off.

I’m rather wondering if the ideal input would be to expose a switch plus a dimmer value. This would make sense as I may wish to turn the light off without changing the brightness level used if the light is turned on again; further, it’d be nice to be able to change the default brightness in response to the total solar radiation.

Thanks @hilbrand! Looks like the forums decided to be a jerk and remove your link. I’ll try and find it.

(side note, I can’t install the eclipse IDE oomph plugin for openhab2 addons development :frowning: EDIT solution here Conflicting Dependencies, Fresh IDE install on Mac Mojave )

I removed the link :slight_smile: because I prefer to have people install the market place version instead of an old version.

Ok, see you found the market place :smile: .

:slight_smile: Yeah. Thanks!

Well, now I have the opposite problem. The switch turns off but it won’t turn on! When I turn it on, I see this in the logs:

2018-12-30 07:59:58.848 [ome.event.ItemCommandEvent] - Item 'MasterBath_Light_Brightness' received command 32
2018-12-30 07:59:58.855 [nt.ItemStatePredictedEvent] - MasterBath_Light_Brightness predicted to become 32
2018-12-30 07:59:58.866 [vent.ItemStateChangedEvent] - MasterBath_Light_Brightness changed from 0 to 32
2018-12-30 07:59:59.301 [vent.ItemStateChangedEvent] - MasterBath_Light_Brightness changed from 32 to 0

Not sure if the switch has a feedback loop? I did uninstall the other plugin and restarted openhab2.

Looking at bundle:list, I only have one version installed:

START LEVEL 100 , List Threshold: 50
 ID β”‚ State    β”‚ Lvl β”‚ Version                β”‚ Name
.... snip ....
258 β”‚ Active   β”‚  80 β”‚     β”‚ TPLinkSmartHome Binding

Ah, I figured it out :slight_smile: I had to delete and re-add my thing for the channels to be specified properly.

1 Like

Please mark the thread as solved, thanks

1 Like