[SOLVED] HTTP Binding: javax.net.ssl.SSLHandshakeException - handshake_failure


I am using the current stable release of Openhab (openHAB 2.3.0-1).

I always got my weather data from the http binding and the homepage http://wetterstation-pliening.info. The homepage has now been changed to https and since then I get the following error:

2018-10-20 18:22:23.193 [ERROR] [org.openhab.io.net.http.HttpUtil    ] - Fatal transport error: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
2018-10-20 18:22:23.198 [ERROR] [ab.binding.http.internal.HttpBinding] - No response received from 'weatherCache'

My items file looks like this:

Number	Temperatur		"Temperatur [%.1f °C]"		<temperature>	(Wetter)	{ http="<[weatherCache:1000:REGEX(.*?Temperatur.*?<th class="col1 leftalign">(.*?) °C.*)]" }

And my http.cfg looks like this:


Before I switched to https everything worked fine? Is this a Java bug? Or does the certificate from https://wetterstation-pliening.info have an error? Chorme does not display a certificate error.

See the post here for possible fix. [SOLVED] Failed downloading Marketplace entries: Received fatal alert: handshake_failure

I found another solution myself:

I have updated Zulu Embedded Java. Only the following version will be installed from the repository:

openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_152-b76)

Meanwhile the following version is available for download on the homepage https://www.azul.com/downloads/zulu-embedded/ :

openjdk version "1.8.0_181"
OpenJDK Runtime Environment (Zulu (build 1.8.0_181-b122)

I installed this manually (https://blog.benjamin-cabe.com/2016/04/05/installing-the-zulu-open-source-java-virtual-machine-on-raspberry-pi) and it works now.