[SOLVED] - HTTP Request Error when using setpoint

I feel like this used to work. Well, I know it did. But its been a bit since I filled the tank and now getting this error when I try to change the tank level and it does not update the remaining propane:


Number PropaneRemaining "Propane Remaining [%.2f Gal]" <gas>


Setpoint item=PropaneRemaining minValue=0 maxValue=300 step=5


[WARN ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/PropaneRemaining' with an invalid status value '230.00 Gal'.

How are you sending this POST? To what binding?

It comes from the setpoint widget on the sitemap, and is a command for the OH Item.

Its a WARN, not an error. Does it actually work?

The widget seems to have sent a value with a QuantityType (Gal)
and Item PropaneRemaining just wants a plain Number

These UoM features are all new, I think we’ll need to know your OH version and which UI you use.

Let me rub a magic lamp … @vzorglub is Gal a supported UoM or is the widget being optimistic?

I am still on version 2.3. Have not had time to do the upgrade. Need to though.

And no, it does not work. Even though its just a WARN it does not update the number. I can try without the gallon.

I took the gal out and now it works. Thanks for the tip. I don’t think i need the gal on there so should be good. Thanks for the tip on that!

Number PropaneRemaining "Propane Remaining [%.2f]" <gas>```