[SOLVED] Hue emulation: bridge not discovered

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: Openhabian
    • Java Runtime Environment: openjdk version “1.8.0_152”
    • openHAB version: 2.5.0
  • Issue of the topic:
    Dear Openhab experts,
    I try to use the hue emulation to connect my openhab installation to echo devices. Unfortunately the Alexa app does not find the emulated bridge. I followed the instructions on the documentation page and forwarded port 80 to 8080 via iptables (and nginx in another try). I swithed into pairing mode via Paper UI but both the alexa app and the phillips hue app do not find the bridge. My real hue bridge is found by both apps.
    In the log viewer I get constantly the following warning:
    [WARN ] [ueemulation.internal.upnp.UpnpServer] - Could not send UPNP response: Cannot assign requested address (sendto failed)
    but I am not sure if this is related.
    I hope someone can help me.

In PaperUI try setting IPv4 address in configuration of binding.


Take a look at this post [hueemulation] Could not send UPNP response

1 Like

The discovery worked after the following settings in PaperUI/Configure Hue emulation:

  • Device Pairing: on
  • Pairing: Add Unknown User-Keys: on
  • Optional Discovery Address: local IP address of Raspberry PI
  • Optional Discovery Web Port: 80

I do not know if it would also work with less settings but at least it did not work only with Device Pairing and Pairing: Add Unknown User-Keys

Thank you to H102 for his tip!

1 Like