[SOLVED] I cant connect with PUTTY to the openhabian

I have entered the wrong password for many times (using putty) and after some time it disconects me and from then i cant conect to the openhabian (“Network error: Connection refused”). If i try to work on RPI with keyboard and screen connected to it, everything is ok, i just enter the correct password and i login, but if i try again to connect via PUTTY it doesnt allow me.
And yes, I’ve checked, the RPI is connected to the WIFI that i am using. Also I enter the correct ip with port: 83.
Please help me fast!
Thanks for any help!

ssh login is on port 22 (if you haven’t changed anything)

1 Like

I have the same problem. But I did not try wrong passwords. I did nothing. Openhab(ian) is running fine, sitemap etc., PaperUI and so on. But I cannot connect from my PC to my Raspi using ssh Port 22 any longer. Even after a hard reboot by power off and on.
Any hint?

openHAB and openHABian are using different passwords for ssh login …

@sihui: Thanx and sorry, I am running openhabian, installed from given sdcard. User: openhabian, Password: openhabian.
Since several months. But it now blocks me. I have no idea.
Openhabian does not ask for a user or password, after trying to connect I get the response “Network error: Connection refused”

Sorry, no idea, maybe trying the steps from the docs again could be of any help:


Thank you, your link is for OH on windows, I referred to the Openhabian on Raspi part.
But it did not help. However, I noticed that log time ( is about 45 minutes behind Windows time. Maybe, this is a problem.

I also tried to put an empty file ssh into the boot partition of the sdcard, which should start the ssh daemon once during boot. No success.

Yesterday, I updated the firmware of the gateway router due to the WPA2 bug. Maybe, this could be the cause of this trouble as well. But I do not understand why. And how to change it.

I tried to uninstall WeatherUnderground binding, as this produced a warning. However, uninstall was not possible and now critical errors occur. My whole installation is broken and I will setup a new one.


Either you are completely on the wrong track or I don’t understand your problem at all.

If you want to do that the page I referred to is the exact correct page.

If you want to ssh into the karaf console of openHAB (if your ARE already ssh’ed into your Pi), you have to use these docs:

But that has nothing to do with port 22.

The page you are referring to is the installation guide for openHABian. For that you don’t have to use ssh at all.
AFTER successful installation you can enable the ssh server and then connect via Putty or whatever ssh client to your openHAB instance.

1 Like

@sihui, I really appreciate your support. Thank you. On the webpage I cited (http://docs.openhab.org/installation/openhabian.html#raspberry-pi) there is a link directly above the screenshot of the console which describes “Ready for more? Connect to your Raspberry Pi SSH console using …” This is what I meant to do: connecting from my PC to raspi using ssh. Sorry if my description was too fuzzy.
I flashed the sdcard from an image backup and was operational after some hours. However, I suppose there is some hidden problem in my installation as this is the second time that I lost ssh access after some months of flawless operation. Using a 16GB sdcard I do not assume a storage overflow due to logs or my rrd4j persistence. I will look for a solution to monitor disk and memory space,a shutdown / reboot option (to avoid sdcard stress by power supply interruption), and a means to free disk space directly from my sitemap. Thenafter, I am not completely lost in case of loosing ssh access.
Thanks again!

1 Like

Hi, you never walk alone. Today i am facing again, the third time, ssh message from putty “server unexpectedly closed the connection”. (It’s enough to drive you up the wall)
Always at the end i did a reinstall of the whole the system. I don’t now why this happens after some months of operation. Last reinstall was in the beginning of march. At any time when i change the config, i make always a backup of openhab. This saves my as. But the pain of reinstalling remains. It takes some hours…

(old post, I know, but still)
A rather generic advice, but if you have physical access to the Pi (connected Montitor and Keyboard) you should login as root locally and watch the system logs:

tail -f /var/log/syslog

and maybe the same with authlog. Usually you can see where it hangs. If you ssh in from a linux box, you may add one or more -v to the ssh command, this gives hints as well.

Hi Tron,

there is no user left to login imho. I face the same problem. Flashing again…


With computers, something working for months and then suddenly breaking does not happen unless there has been a change somewhere or something has degraded.
With openHAB with persistence writing quite a lot to the SD-card of a pi, that can fail over time. Try using a new card.
@haugan: what do you mean by “no user left”? There’s always root, and with physical access to the card you can always reset the root password from another machine.