[SOLVED] iCloud Binding


I’m using the iCloud Binding and it worked from September last year until now. Since 2 days it shows the ssl-connection error again.

java.util.concurrent.ExecutionException: javax.net.ssl.SSLHandshakeException: General SSLEngine problem

Can you help me with it, or is there some work arounds?

I’m using openhab on the raspbian OS and I updtaet it recently, could be this the reason the new update?


Have you stopped OH and cleaned the cache since updating or the problem began?

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2 or sudo reboot

If that does not work you can uninstall the binding via PaperUI and install the jar file manually.

Place this file in usr/share/openhab2/addons then restart OH. If the binding does not load try bundle:restart and give it a few minuets.

EDIT @maxbe23 I put the wrong jar file link but now the above is correct and should work to fix your issue. If you have an issue with unresolved requirements such as gson then this additional jar file is needed:

Thank you very much.

Unfortunately the bining is not starting. At the karaf console it is not listed as running.

Mhhh… Do you know how to fix it?

I put your last uploaded file into the addons folder and normally it works for the added bindings.


From the console use bundle:restart for the binding. Forgot to mention that above but wasn’t sure it was needed.

BTW what version is showing in the console?

It does not start at all. It is not initialized. At the bundle list.

Whats the version number and do you have anything in the logs regarding the binding?

==> /var/log/openhab2/openhab.log <== 2020-01-26 21:29:28.067 [WARN ][org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.icloud-2.5.2-SNAPSHOT.jar org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.icloud [191] Unresolved requirement: Import-Package: com.google.gson; version="[2.8.0,3.0.0)"

This is the log.

It’s looking that I need some new gson version, right?


Add this jar file to usr/share/openhab2/addons and you should be good.


1 Like

You are a fuckin god :smiley:

Thank you very much. You saved my night :wink:


I edited the post above with the links to have a complete solution. Please click (the square box) on that post to mark topic as solved.

Thanks and glad to help.

I installed the binding referenced here into my addons folder and restarted OH2 after having removed the stock binding via PaperUI, but I’m still getting SSL errors. I’ve done this sort of thing before with snapshot bindings, so I’m not sure what I’m missing. Any thoughts?

What version of OH are you on?

Sorry, 2.5 release on an rpi4

“My Break-Dancing days are over, but there’s always the Funky Chicken” – The Full Monty

Stop OH, clean the cache, and restart two times and see if that helps. Just make sure you give OH time to fully restart before the next restart.

Thanks for the reply, but I did do these things.