[SOLVED] Illegal reflective access

HI all,
I am new and I don’t know if this is the right place where to put this message.
Here is what I get from a systemctl status openhab2 command:

openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
Active: active (running) since sab 2019-01-26 17:01:27 CET; 21min ago
Docs: https://www.openhab.org/docs/
Main PID: 1372 (java)
Tasks: 158
Memory: 1.3G
CPU: 1min 34.098s
CGroup: /system.slice/openhab2.service
└─1372 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.userdata=/var/lib/openhab2 -Dopenhab.logdir=/var/log/openhab2 -Dfelix.cm.dir=/var/lib/openha

gen 26 17:01:27 aldo-fw-b systemd[1]: Started openHAB 2 - empowering the smart home.
gen 26 17:01:43 aldo-fw-b karaf[1372]: WARNING: An illegal reflective access operation has occurred
gen 26 17:01:43 aldo-fw-b karaf[1372]: WARNING: Illegal reflective access by com.thoughtworks.xstream.core.util.Fields (file:/var/lib/openhab2/cache/org.eclipse.osgi/101/0/.cp/lib/xstream-1.4.7.jar) to field java.lang.reflect.Proxy.h
gen 26 17:01:43 aldo-fw-b karaf[1372]: WARNING: Please consider reporting this to the maintainers of com.thoughtworks.xstream.core.util.Fields
gen 26 17:01:43 aldo-fw-b karaf[1372]: WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
gen 26 17:01:43 aldo-fw-b karaf[1372]: WARNING: All illegal access operations will be denied in a future release

I upgraded OH2 to 2.4 by apt-get update and apt-get dist-upgrade
and since then Astro, Network and NTP binding stopped working. I gave the commands
openhab-cli stop
systenctl stop openhab2
openhab-cli clean-cache
NTP and Network where working while astro was not.
I tried to uninstall astro 2.4 and install astro 1.0 but everythings went wrong and I couldn’t even get any OH2 interface. So I gave again the commands above to clean cache. This time only NTP was working and I displayed the stetus you can see above.
I use knx and all my Items are saved.
I run ubuntu 16.04 server
Could you plase tell me the best way to have all bindings working ?
Thank you so much

I guess you are running java 9/10/11. Try running java 8.

I installed zulu 8 bat the apt-get downloaded zulu 9 so next days I will try to uninstall zulu 9 and reinstall the 8.
Thank you for your answer.
it would be nice if someone would tell the ubuntu maintainer to upgrade just openhab2 and not the java package.
Have a nice day

Sorry, I was wrong, zulu-9 has java-8 in it.
Any way after an attempt of downgrading zulu I cleaned everything and now I run:
openhab2 2.3.0-1
openhab2-addons 2.4.0-1
openhab2-addons-legacy 2.4.0-1

binding-astro 2.3.0
binding-http1 1.12.0
binding-knx1 1.12.0
binding-network - 2.3.0
binding-ntp - 2.3.0

Everything seems to be ok but if someone knows what was wrong in the upgrading from 2.3 to 2.4 this would help for the future; I don’t think to be the only one running OH2 in ubuntu server 16.04

Many thanks to all of you that spent time to develop this wonderful product.