[SOLVED] Innr SP120 and Zigbee Binding


I hope I’m in the proper section for this topic.
I just got into openHAB and successfully added a Telegesis Zigbee USB Stick.

OpenHAB is running on a QNAP NAS and works like a charm. I added a few OSRAM Plugs and Lights to it (still having trouble with the RGB lights but whatever) and I thought I could use an INNR SP120 plug to measure the power usage of an appliance because the Osram ones don’t show proper stuff.

Unfortunately, I can’t pair the INNR SP120 with the openHAB.
The Telegesis discovers it and presents it as "Unknown Device ".
Sadly that is all I got so far. The Osram Plugs and lamps work fine. They take a few seconds and then get identified properly.
Has anyone information about that behavior?

PS: I’m running openHAB 2.5.0 Build #1549 because this is the only version that I could update to from my QNAP.

Please provide the debug log from the join and I will take a look. If you can also provide the network XML file, that might be enough, although it depends on what is (or isn’t) happening.

The XML file is in the userdata/zigbee folder.

thanks for the quick reply. Here is the

2019-03-08 16:45:37.987 [home.event.InboxAddedEvent] - Discovery Result with UID 'zigbee:device:05000E5F:00158d000362473c' has been added.
2019-03-08 16:45:46.707 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:7cb03eaa00b1fb57' has been updated.
2019-03-08 16:45:47.436 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:84182600000e381e' has been updated.
2019-03-08 16:45:49.082 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_telegesis:05000E5F' has been updated.
2019-03-08 16:46:04.737 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:84182600000e381e' has been updated.
2019-03-08 16:46:05.869 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:7cb03eaa00b1fb57' has been updated.
2019-03-08 16:46:08.516 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_telegesis:05000E5F' has been updated.
2019-03-08 16:46:52.902 [me.event.InboxRemovedEvent] - Discovery Result with UID 'zigbee:device:05000E5F:00158d000362473c' has been removed.
2019-03-08 16:46:52.909 [hingStatusInfoChangedEvent] - 'zigbee:device:05000E5F:00158d000362473c' changed from UNINITIALIZED to INITIALIZING
2019-03-08 16:46:52.909 [hingStatusInfoChangedEvent] - 'zigbee:device:05000E5F:00158d000362473c' changed from INITIALIZING to UNKNOWN
2019-03-08 16:46:52.920 [nt.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:device:05000E5F:00158d000362473c changed to UNKNOWN.
2019-03-08 16:48:20.935 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:00158d000362473c' has been updated.
2019-03-08 16:48:44.941 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:00158d000362473c' has been updated.
2019-03-08 16:49:25.136 [hingStatusInfoChangedEvent] - 'zigbee:device:05000E5F:00158d000362473c' changed from UNKNOWN to ONLINE
2019-03-08 16:49:25.147 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:05000E5F:00158d000362473c' has been updated.

zigbee-network–zigbee_coordinator_telegesis_05000E5F.xml (205.4 KB)
openhab.txt (460.1 KB)

Hope this helps in any way. The openhab-debug file seems awfully spammy so I have no idea if something useful might be in there for you :smiley:
If you need anything else, please let me know. I would love to get this to work properly or help find a solution if something is not right (But I assume that it’s just me being a dumdum and new to this stuff )


I use the Innr120 plug without problems with the Hue binding. Are you sure you pushed the small button on the plug when the binding/USB stick is in pairing mode?
The Innr 120 has no hardware to measure its energy, as far as i can find in the minuscule manual. Where did you read it can ?

Thanks - this all looks good in that it is all the info I need…

I think that the issue is probably related to the profile this device is using. It is not an HA (ie Home Automation) device, which is what the binding is - instead it’s reporting a ZLL (Light Link) device.

Most devices that are ZLL also work with HA commands, but this one doesn’t seem to respond to any ZCL commands, and I’m assuming that is why.

This is an area I’m looking to enhance in the binding (or more specifically, in the low level libraries) - ie to support multiple profiles. That said, ZigBee no longer supports profiles like this under ZigBee 3, so any new devices over the past year or so (since ZB3 certification was rolled out) should work correctly under HA.

The device does report that is supports these features, so my assumption is it does have these facilities (but they might just report this incorrectly of course).

Alright that sounds promising, thank you so much. I was really confused on why this thing won’t work and because the 3 picture-manual was really bad at explaining the light status of the thing (red / blue) I was pretty sure I borked something in the pairing process.

Because I can’t bind it properly I will return the plug. Is there anything I can contribute to before I send it off?
Thanks for the look and I appreciate the big support in this community!

No - I don’t think so - thanks. I pretty much know what needs to be done, and have it partly coded, but it’s quite a large change, so it’s just not made it to the top of the list yet…

No worries. I’ll keep an eye out for an update when it drops.
Thanks for your great work. Really appreciate that. I think I’ll re-order one of these plugs when I see that there were some changes made. Don’t rush anything :wink:
Have a great weekend!

@BlackEternity It’s a Telegesis issue, the plug works correctly with the Ember stick (see #473 for details).

I can confirm that the plug does indeed provide the relevant channels and that they are working as expected.

1 Like

Do you mean that you can measure power or current with the Innr SP120 ?

Yes, both. Voltage as well.

Hi, has anybody managed to use/see power and voltage consumption of the SP120 connected via HUE Bridge? I can change the state via a switch item in Openhab bute had no success on the consumption.

Switch  INNR_KG_PLUG_DRYER_Toggle              "Trockner"        <poweroutlet>   (KG_Boiler, gPower) { channel="MYHUEBRIDGE:27:switch" } 
    String  INNR_KG_PLUG_DRYER_Power               "Trockner Power"        <poweroutlet>   (KG_Boiler, gPower) { channel="MYHUEBRIDGE:27:power" } 
    Number  INNR_KG_PLUG_DRYER_Voltage               "Trockner Spannung"        <poweroutlet>   (KG_Boiler, gPower) { channel="MYHUEBRIDGE:27:voltage" }

I had seen some used the channel voltage and power in deconz but as stated above I connect the plugs via Hue.

What would be the correct channel and item type?


It might be best to ask this in a separate question since the title of this is linked to the ZigBee binding - not the Hue binding.

@Shu asked the same question before (in other topic). See here. I think he copied/pasted it here without changing his questions.

This questions should be:
If I switched from Hue binding to Zigbee binding, which channels would be available for SP120?
What would be the correct channel and item type with zigbee binding (if there are any)?

Are there more channels available than just a “switch”? e.g power/voltage (like in deCONZ binding)…

It doesn’t matter if you switch from Hue or not - the device will be reset, and it will be the same as if it just joined the network.

Sorry for hijaking this thread, I posted the question also in another topic but really I should have opened a new one.

Nevertheless, it seems like with my current setup I am not able to see the consumptions. I might give the deconz bining another try but I remember when I last tried it there were severa issues as the emulated Hue bridge was interferring with my actual hue bridge in OH.

Thanks anyways :slight_smile: