[SOLVED] Intermatic HA03 - Unknown Device

Greetings! I’m setting up OH2 in a test environment. My primary type of zwave device in the house is Intermatic HA03s (zwave dimmer switches). When including, OH2 does pick it up under Things, but it’s listed as an Unknown Device and says it “is not in the database”.

I was successful in including and using a HomePro ZDP200 dimmer switch, so I feel like it’s not the process where I’ve gone wrong.

Can someone guide me on getting this entered into the database?

Thanks for your time,


You can submit it to the zwave database yourself:

Or file an issue and chris will add it when he can. I know he is pretty busy right now so it might take a little time.

Thank you - I will get it added. Much appreciated!


I added the Intermatic HA03 to the DB tonight. I believe the next step is to do a pull request, which I’m not familiar with at all. @chris, when time allows, can you do a PR?

Thank you for your time!


Will do. It might be Monday or Tuesday when I get home - internet is a bit flakey most of the time in India :wink:

No problem - thanks for your reply. Safe travels!

Well, I really must be doing something wrong here. I think I see where the HA03 was added to the database, but I still wasn’t able to have it recognized in OH2 (openhabian). I blew away the system, started all over with a fresh download of Openhabian using the documentation. If I understand the docs, this should install an up-to-date system, and when I add the zwave binding, that should install an updated database. Yet, when I add the HA03, it’s still an unknown device. I can use HABmin to reinitialize the device, and I do see the LED blink so I know they’re communicating, but that’s the extent of my success. I have deleted and re-added this device (and a couple of others numerous times) with no luck.

I use quite a few of this same model on OH1.8, so I wasn’t thinking it would be such a challenge to get it rolling in 2.0. I apologize for being so needy!

Any guidance, or a nudge in the right direction, would be greatly appreciated.

Thank you!


Okay - so when I look at the supported devices for the zwave binding under HABmin, I do not see HA03 listed. Apparently the database isn’t getting updated on my Pi when I uninstall/reinstall the zwave binding. Can someone give me any other tips on updating my local DB?


Finally - SUCCESS!

I found the Package Repository Installation notes at this link, I followed the steps for adding the SNAPSHOT release to my apt sources list, then ran

sudo apt-get install openhab2-addons

Finally - I have the latest zwave database loaded locally… and the HA03 works like a charm.


I have the same issue with the Intermatic HA-03. Is there a different way to update the database without going to the snapshot version of openHAB? I have uninstalled and re-installed the binding but that didn’t seem to do it.

I just installed openHABian for the Pine64. I have the Pine Z-wave module and everything worked just fine.

No - unfortunately this is how ESH works…