[SOLVED] iOS app - allow choice

Please allow us to use the older version. App updated today and now I cannot access anything. A simple choice.

I don’t want a full blown user interface on my phone, a simplistic site map works so much better and you just broke everything for my family :cry:

Not good.

1 Like

I have the same issue, I went to use the App today and it no longer displays my home site map page, instead I now have a full openhab application showing which not what I want.
Is this intended behavior?

I experienced the same thing after the update but was able to choose the options (three bars) and select my sitemap from the Sitemaps section and it’s back to how it was. Working quite well from my perspective.

1 Like

So yeah I just went looking for this.
It’s literally only visible for the first second or so on opening the app and disappears to not be seen again.
Thanks for the solution :+1:

Thanks for your observation, for me I can’t click it fast enough.
My process is, kill the app.
Launch the app, three bars appear on the screen for 0.1 seconds.
I have tried best to anticipate and still can’t select, I suspect the control is disabled as soon as I see it.
I have iPhone 12 maybe it is just to quick for me.
Long story short, I suspect the control is intentionally hidden or mistake with how long it should be displayed on the screen, hopefully the latter because I have lost access to all the hard work I have put in creating my setup.

Can you press the orange square with the arrow pointing right

That’s at the top of the screen and always seems to be there

Hi Lucus
I can select the orange square with arrow.
Once I do this I can get to the settings page.
I select Home under Sitemaps and get an error “Response status code was unacceptable: 401”
I have tried to change the Main UI settings “Default Path” but there is no option to change it even though it has the + sign, my only choice is ok or cancel.
The current path is “/”.
I am assuming this would be where I could set back to my sitemap that worked pre upgrade to latest app.
I have upgraded Openhab to 3.3 as I thought maybe the app change is not compatible with OH 3.2 M5, however no change after upgrade.

Hmm I have managed to get my sitemap to display again.
I noted when I switched off wifi on phone the site map loaded without any errors.
Under settings I switched off “Always send credentials” and then turned wifi back on.
Sitemap is now loading.
While trying to troubleshoot the issue I must have turned on “Always send credentials”.
Anyway it is working now which is great.
I will have to do some reading about the purpose of “Always send credentials” and if there is a concern for turning it off??

In a recent iOS app related thread (I think) it was pointed out that you should “always send credentials” when you connect to your local OH server via https. I use http therefore it is off. I found connecting locally via https was slower anyway. I hope I got that right.

1 Like